Anybody else getting a lot of crashes in Windows?

I've tried running just from the onboard storage, an mSATA SSD, Windows 10, Windows Server, and all combinations in between, but no matter what I try I seem to get to a point after a while when the board crashes and immediately reboots. Then after a boot or two the startup repair dialogues come up and then fail to get anywhere. It always ends up bootlooping into the recovery options and I can't get it back to the desktop environment other than in Safe Mode.

I'm thinking it might be something to do with the graphics driver, but as Win10 grabs drivers automatically it could be any of them, but I'm even struggling to find minidumps to try and trace it and the log files are giving me nothing.

Any ideas?


  • Andy NicholsonAndy Nicholson New Member Posts: 61
    Thinking the graphics driver is definitely to blame, I removed the current drivers...

    Intel HD Graphics

    ...and everything seems to have settled down again (for now) so I'll keep looking for a solution.
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    Tried rolling back a version, both and show the same behaviour...
  • FabrizioFabrizio AAEON Posts: 123 mod
    Hi Smadger,

    very strange.
    We are going to have a look at it.
  • WereCatfWereCatf New Member Posts: 201
    With frequent, random crashing the first thing I always do is run memtest86, just to make sure there isn't anything wrong with RAM. My boyfriend's PC seemed stable otherwise, but whenever the GPU came into play, like e.g. when firing up a game or similar, it'd crash, and it turned out to be one of the DDR3-stick having gone bad. I dunno why using the GPU had such an effect, when the issue wasn't the GPU, but there it was and as such I'd say there isn't much harm in you running memtest86, even if it doesn't find anything wrong.
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    Yeah that's on my list of things to try - I work in IT so have all the tools pretty close to hand - but I've been a bit busy with "real work" recently so had to put it to one side for a while, as much as I'd like to convince my boss otherwise :)
  • WereCatfWereCatf New Member Posts: 201
    What, work? Bosses? Blasphemy! Everyone knows fun, coollies tech-toys should come first!
  • AlingAling Administrator, AAEON, UP reseller Posts: 561 admin
    I got some feedback from our engineers. He did experience some crash while installing Windows 10 via CD ROM. It seemed the USB type CD-ROM drew too much power from the board, then it result in crash. After he changed the power supply to [email protected], the crash was resolved.
    While running high performance program such has heavy graphic, or burn-in test, [email protected] is recommended.
    I hope this could help.
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    edited June 2017
    Thanks for taking the time to have a chat and suggest things, but I'm afraid it's not much use.

    Windows (all 4 versions I've installed from 2 separate USB thumb drives, and to the local storage and an mSATA SSD) work absolutely fine, they install, upgrade, restart, run applications etc absolutely fine.

    I can even install the drivers (all 3 versions available from the Inel site, and the ones supplied in another post on this site) as long as I don't restart the board after the install everything is ok.

    The second I restart after installing the HD Graphics drivers the problem starts (and only the graphics, not the Intel Audio package that's combined with it) as soon as it starts to load the logon UI and desktop shell it immediately reboots without creating any logs at all, and the only way I can get things back up and running again is to boot to safe mode (no graphics drivers being used) and remove the drivers.

    Memtest doesn't reveal any issues.

    It does it even when installed to the onboard storage with no devices attached at all, and the power supply is a full 5v 6A supply. I wouldn't describe booting as a "high performance" program either :)

    I'm happy to try something to fix things, but I'm rapidly coming to the conclusion the board is faulty :(
  • FabrizioFabrizio AAEON Posts: 123 mod

    did you try the driver version : ?
  • AlingAling Administrator, AAEON, UP reseller Posts: 561 admin
    We spot one possible root cause.
    Release Graphics driver is not 4534
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    I'm pretty certain I've tried all of the ones available, but I will check this evening when I get home, thanks.
  • FabrizioFabrizio AAEON Posts: 123 mod
    please let us know the exact configuration ( cpu, ram, emmc, , power supply, other peripheral attached if any - ssd ? wifi ? , exact version of Microsoft Windows etc)
    we will try to duplicate the issue since we didn't experience it
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    edited June 2017
    I have tried soooooo many combinations it's getting silly. But the last one I tried was as plain and vanilla as I could make it....

    Windows 10 Enterprise Creators Update (1703, ver 10.0.150063), straight out of the box, no updates and never connected to the internet.

    Celeron N3350
    2GB RAM
    16GB eMMC (onboard, although have tried lots of alternatives, USB on the go / various mSATA SSD etc)
    5v 6A power through a calibrated bench power supply
    No network
    USB mouse
    USB keyboard
    DisplayPort being used (but again have tried the HDMI port too with the same behaviour)

    Straight after an installation and 2 reboots to prove everything was operating as expected I installed the drivers downloaded directly from the post on this forum. The process did not complete and the board crashed before completion.

    I have also tried 4590, 4627 and 4664. all crash the board after rebooting and have to be removed in safe mode.

    I also noticed that Intel have released another new driver in the last few days that was not on their site before ( so I also tried these drivers, which also crash the board.

    The installer packages also contain the Intel Display Audio drivers, I have also tried not installing these, or installing them separately for all the above versions with the same results leading me to believe the issue is with the graphics.

    I have now tried 5 different drivers, over 4 different versions of Windows 10, using 4 different types of storage, 2 power supplies, 3 HDMI cables, 2 DisplayPort cables, 2 wi-fi adapters, and 4 different installation media, and pretty much every combination possible of all of these since last Thursday, but I always get the same behaviour. If I'm doing something wrong at this point I'll quit my job as I don't deserve to work in IT support :)

    ps - if I have to return this for a replacement it would be a real shame for the models to get mixed up in the post and a Pentium model sent back in return hahahahahah :) :whistle: (wishful thinking I know)
  • Andy NicholsonAndy Nicholson New Member Posts: 61
    edited June 2017
    Oh, and by the way, I know that MS says you need 32Gb to install Windows, but this was just to strip everything back to it's bare minimum and start from there. There are still 2.5+ GB of free space after the install and I can launch driver install processes just fine. The same behaviour and issue happens on 128GB SSDs too.

    Also given that nobody else has reported any similar issues, and I think I'm right in saying I've demonstrated something is wrong, how do we go about getting a replacement sorted?
  • AlingAling Administrator, AAEON, UP reseller Posts: 561 admin
    Hi smadger,

    Not sure what's the problem on the UP Squared, however, it sounded very abnormal.
    Can you drop us an email to [email protected] with your Kickstarter information?
    We would like to proceed a replacement for you.

    Thanks for so many tries... :-)
  • Robert SheltonRobert Shelton New Member Posts: 110
    Did the replacement board resolve this problem - i.e. root cause was a hardware problem? I ask bc my DisplayPort does not work with driver version I understand from another forum member that the DisplayPort works when using v4550. Given your reports of crashes, I am hesitant to install v4550.
  • AlingAling Administrator, AAEON, UP reseller Posts: 561 admin
    According to our engineers, the correct graphic driver is 4550 and we didn't experience any crash issues.
    We will soon come up with Windows 10 installation SOP to help.
  • Robert SheltonRobert Shelton New Member Posts: 110
    Hi Aling,
    Thanks for the very speedy reply! So I gather that the concern raised in your June post about 4550 is superseded. I will install 4550 to see if that fixes my DP-not-working issue.
  • Edward ThomasEdward Thomas New Member Posts: 20
    edited November 2017
    I would say that the problem has something to do with the graphics driver. I am on my second board now and neither of them will operate with anything other than the Microsoft Basic Graphics Driver. 800x600 resolution is pretty much useless. Just like the other posters, if I try to change the graphics driver to an Intel driver (be it the one provided by UP or one from Intel directly), the machine goes into an endless series of boots and crashes (just before you get into Windows) until the repair screen finally comes up and you have to go into Safe Mode and remove the Intel driver. This is running Windows 10 Pro, which the machine is supposed to be able to handle. I have tried updating the BIOS as well with no change. I have jumped through every hoop that UP/Aaeon has put out without success and am only told that the problem doesn't occur with their board.

    I also tried to install SSD and wireless boards and they appeared to not work either. I had high hopes for using this product for my business but it appears to be junk at this point. Better off keeping with the far more expensive NUC I guess. UP is unable to come up with a reason for the problem or a solution. I'm in the US so I have to purchase from Mouser unless I want to pay some ridiculous $60+ tax (which I assume is some kind of estimated import tax which they have no right to charge) to order it directly from UP. Unfortunately, Mouser is somewhat difficult to deal with when it comes to returns and UP/Aaeon will not deal with RMA/warranty issues for their products purchased through their dealer (a poor way of doing business). Overall, it has been a very disappointing experience, and while I have a standard UP Board on the way, I may very well not bother with it (because it would likely have the same issue) unless someone has come up with a solution to this problem.
  • Robert SheltonRobert Shelton New Member Posts: 110
    edited November 2017
    Hi @dsproducts,

    Verify that your power supply delivers [email protected] reliably. For a time, I was using the [email protected] that I must have received with the Kickstarter Up2 campaign. That supply works fine for the original Up-board plus hats / accessories, so I have a bunch of them in the lab. But 4A is not sufficient to drive dual monitors, multiple USB peripherals, or demanding applications on the Up2. I experienced exactly the cyclic failure-to-boot symptoms that you describe, often having to disconnect monitors and USB peripherals to break out of the boot loop. Someone else on the forum pointed out that cause to me, and switching to a 6A resolved that set of issues. Although other supplies will work just fine, the one I use is from the Up store.

    NB, I am running 64bit Win10 Pro v1703. My Up2 is 8Gb, N4200 CPU at 1.10Ghz. My monitor is a touchscreen HDMI, USB-c powered from the Up2, at 1920x1080 resolution. I have a 128G SSD and bluetooth / wifi card installed. I also run a second WiFi via USB; and drive an ASUS HDMI monitor at full resolution about half of the time (shared with my iMac). That should provide a benchmark for my loading on the board.

    If useful, you can track down the details by searching for my other posts.

    As for customs issues, I have not experienced any problems with shipments from AAEON into the US. My objection has been the cost of FedEx shipping that starts at $24 and climbs rapidly from there. I've spoken w customer service about that, but they believe FedEx is the lowest cost option. I strongly second your comments on Mouser. I wish that AAEON would find a different US distributor. Mouser's customer service was horrible.

    With respect to the original Up-board units, I've found them to be reliable. I use a raft of them as micro-servers in a big-data lab. The 8GB RAM on Up2, however, will better serve you as a Win10 user. Just received my Up Core. I've not had time to work with it yet, so can't yet convey any results there.

  • Edward ThomasEdward Thomas New Member Posts: 20
    Thanks for the feedback. I am using the same board as you. I have tried using a couple different screens with HDMI. I gave up on the SSD and wifi card installation since they weren't going anywhere and decided to concentrate on the graphics problem since it is the first and most obvious problem.

    I have been using a 5 amp power supply but just in case, I went to my bench top power supply which provides 10 amps and no joy. I tried installing the graphics drivers several times in different ways (e.g., the UP drivers, Intel drivers, safe mode, etc.) and the results were the same. The necessary Intel graphics driver will simply not work.
  • Edward ThomasEdward Thomas New Member Posts: 20
    So I got the UP Board in today and installed Windows 10 Pro. Even during installation I could tell something was different from the UP2 board since everything was in high resolution. After installation the screen resolution was set at 1920x1080 (no other choices). Now the interesting thing is that the graphics driver is the Microsoft Basic Display Adapter just like with the UP2 but at least this time it is allowing for a reasonable resolution. I did a driver update through the device manager and the Intel HD driver was automatically installed. Now the screen works in high resolution with various resolutions available to select. Completely different experience from the UP2.
  • Robert SheltonRobert Shelton New Member Posts: 110
    Glad to hear the Up-board install went smoothly!

    5A might work given a minimally loaded Up2. 10A more than covers the bases. Does your bench supply allow you to see the actual current and voltage draw? If not, it may be worth picking up a meter that can be plugged between the Up and your supply's barrel plug. I've used one from - probably obtained from Pimoroni or Adafruit; but there are others that work as well.

    Please check the power lead to ensure that it makes a firm fit on the board. I have experienced problems with some supply leads making poor connections, causing crashes. Had this experience on both generations of Up: slight movement of the plug at the board causes a crash.

    Sorry to bother you with nit-pickies. I'm scouring for clues. Although I'm not an EE (or possibly because I'm not an EE!!), I've had some rough times debugging power issues on a variety of projects.

    Offhand question about the boards: when (time frame) did you receive the Up2 boards? Are the serial numbers close in sequence, or are they from different time frames / batches? Have you reflashed or updated the BIOS on either? Have you returned the problem boards for AAEON to examine?

    Have you loaded either Up2 with AAEON's Linux instead of Windows? Although we're both using Win10 Pro, are you certain that you're using the current/correct ISO and word size? My machine is in use at the moment, so can't reboot to check... but does this BIOS have any 32/64 bit settings? One of the machines I've been working with in the lab has such. Don't recall if Up2 does. Also check BIOS display settings. If Linux drives the HDMI full resolution, something from your BIOS or OS image must be wrong.

    And - just verifying for the sake of thoroughness - are you using the same HDMI cable and monitor with all 3 boards? Have you tested with a different cable? Are you using the HDMI rather than a DP converter cable on the Up2?

    Hang in there! I know the Up2 works, albeit bad boards do happen. I also know a bunch of us have experienced difficulties along the way. It can be crazymaking. Once I got past the power and driver issues on my board, though, it's been more reliable than my iMac... which, depending on your view of Mac, might or might not be an endorsement... so I'll just say my Up2 has been reliable... :)

  • Edward ThomasEdward Thomas New Member Posts: 20
    The bench supply showed a peak around 2.5 amps. I have used two different power sources now with good leads and the socket on the UP2 appears to be fine.

    I received both boards in November but I didn't note the serial number on the first one. However, they are likely close since both came from Mouser's stock over the period of a couple weeks. Unfortunately, since I bought the boards from Mouser, I can't return them to Aaeon for evaluation.

    On Aaeon's recommendation, the BIOS was updated on both boards when the problems became apparent.

    BIOS doesn't have a 32/64 bit settings but the most recent version does have a OS Selection which has been set to "Windows" as recommended by Aaeon.

    I haven't tried Linux since I have no real knowledge of the operating system. Maybe I will give it a try though. The Windows 10 Pro is the most recent download image from Microsoft.

    I have tried different HDMI cables but have not tried a DP cable since I don't have one. But that can't be the problem since the monitor detection is fine, it's the graphics driver that is the problem.

  • Robert SheltonRobert Shelton New Member Posts: 110
    edited December 2017
    Hi Ed,

    Definitely looks as though both boards came from the same batch.

    I recommend the following steps on one of the Up2 boards - no need to try more than one board:

    - Attempt loading Up's Linux. The load process uses the same approach for loading Win.

    - Assuming load succeeds (machine boots)... if you see a login prompt, log in as root - you can find login information on the Community or in the downloadable docs - try searching for "ubilinux root default password" or variations thereof. All of my installations have been customized, so I don't know the default.

    - After login (or after startup if no login is requested, as some GUIs seem to do), you will see either the Linux desktop or a shell prompt

    - If a shell, the default screen resolution should be obvious or determinable from font size - does it look right or like 800x600? This is indicative, not necessarily conclusive, if you are seeing 800x600.

    - If a desktop, do you see what appears to be a full desktop in a resolution other than 800x600? Again, indicative. If unsure (the desktop will look different from Win, so may not be clear if it's overflowing the screen), feel free to post a mobile phone snapshot of the screen.

    If you could attempt these steps, it would give us a place to start. Where we'd go next would depend on whether you land at a GUI or shell.

    BTW if your monitor menu can display the running resolution in the scenario above, that would be a big help.

  • Edward ThomasEdward Thomas New Member Posts: 20
    Well now this is interesting. I installed Ubuntu and the screen resolution is great. So this means there is a compatibility problem with the Windows graphics drivers.
  • Edward ThomasEdward Thomas New Member Posts: 20
    Still no go. Tried installing Windows 10 Pro 64 again and updating the drivers with those supplied by technical support and I still can't get the graphics driver to update to the Intel driver. It simply crashes each time I try.
  • Robert SheltonRobert Shelton New Member Posts: 110
    Sounds as though your board and BIOS are ok - otherwise Ubuntu would not work.

    A couple of items to check... is your release number the same as mine (64bit Win10 Pro v1703)? Could you try obtaining your ISO and building the usb-thumb drive loader differently? I am suspecting that the problem is in one of those. Suggestions below for testing. May also be that the wrong drivers are getting loaded, or that a BIOS update more recent than what I'm running has an issue. I need to think further on how to test these possibilities.

    I recall experiencing two problems loading Win10 on my Up2. The gist is (a) I pulled down a version of Windows that could not work on Up2, and (b) I was incorrectly building the usb. I can track this down in the next couple of days - heading out now, so the quickest solution may be to search for my prior posts on loading Win10 on Up2. I recall there's a post from Aling Wu that talks about which Windows ISO to/not use. For building the usb, download Rufus-2.17 onto the Win machine you're using to build the ISO. There are instructions on the forum for setting the Rufus parameters - and I think I documented some of the ins and outs of using those as a first-timer. Please give this a try. I can also dig further Sun PM or Monday when I'm back.
  • Edward ThomasEdward Thomas New Member Posts: 20
    I have version 1703 as well. I can create the installation drive again, but I have used this one on numerous computer projects in the last month (including most recently the standard UP Board) so I can't really see it as being the problem. The drive as created using Microsoft's creation tool for making it.
  • Robert SheltonRobert Shelton New Member Posts: 110
    Ok, I wasn't aware that the install drive was known working - may have missed that in your posts. No point in re-creating just yet. Let me look thru my posts and notes. For some reason I recall the installers being different, but that may have been driven by something project-specific that I was doing at the time.
Sign In or Register to comment.