can't install OS / the board doesn't respond

Hi

I am trying to setup my up board. Recently received. But it is simply not working. As I power up upboard logo comes up and after that nothing no matter what I do. I have USB plugged in and I have tried pressing F7 nothing happens. Though sometimes a few colored screens cycle through on screen if I keep pressing the F7 repeatedly even before the up board logo comes up.

Things I have tried so far
1. Different usb sticks.
2. DIfferent keyboards
3. Differnt displays
4. Using different options in RUFUS image creater. like MBR and GPT.
5 I have tried simply using dd to create the pen drive

No luck, I have started to believe that there is something very wrong with hardware. The only thing that I have not tried yet is a different power supply. But I doubt anything wrong with supply as the current power supply is rated at 5v 3A. And I use the same supply for raspberry pi 2/3 all the time. It is USB type, for pi I use the micro usb cable. In case of up board I plug the usb to barrel type cable with the same supply.

Regards,
Pritam

Comments

Sign In or Register to comment.