Hung in splash screen "UP bridge the gap"

This happened after a bad GPT and possibly bootloader was flashed. Bios wasn't touched.
The splash screen comes up.. but it hangs there. F2, F7, F10 have no effect.
I've tried disconnecting the battery as well.

Suggestions?

Comments

  • Bruce J BeareBruce J Beare New Member Posts: 7
    poke!
    Anyone know how to get back "into" bios setup to I can recovery my boards?
  • DCleriDCleri Administrator, AAEON Posts: 699 admin
    Hi BJBeare,

    Can you give me some information on your board and the steps you tried before getting stuck on the BIOS Splash screen?

    Thanks!
    Daniele
  • Bruce J BeareBruce J Beare New Member Posts: 7
    I loaded our kernelflinger.efi program and started fastboot.
    The problem occurred when I flashed the gpt table with fastboot. Likely something is messed up with the GPT and it is causing bios to hang.

    I've ordered a serial cable (I don't have one of those flat connectors around) to see if I can get some additional debug from the board.
  • MarcelloMarcello New Member Posts: 156
    BJBeare wrote:
    poke!
    Anyone know how to get back "into" bios setup to I can recovery my boards?

    I had a similar situation and I could recover by disconnecting the backup battery and waiting 15 minutes before rebooting... hope it helps
  • Bruce J BeareBruce J Beare New Member Posts: 7
    Something along those lines seems to work...
    I'm not entirely certain of the procedure, but the following got the board back:
    1. disconnect power and battery
    2. wait an hour
    3. reconnect battery then power
    4. system still appears hung.... BUT after a long time (at least :30 minutes), the boot to the bios prompt completed
    5. after flashing a good .gpt on the emmc... the hang issue disappeared.
  • DCleriDCleri Administrator, AAEON Posts: 699 admin
    I am glad that you sorted the issue with the suggestions from MarcFinns.

    We will add these notes in the FAQs sections we are creating on the UP Wiki.

    thanks!
  • Jesse KaukonenJesse Kaukonen New Member Posts: 42 ✭✭

    Resurrecting this old topic.

    We also had this problem. The Up behaved as follows:

    With a HDMI + keyboard connected, the Up booted into the logo screen, but the normal "SETUP" text at the top right corner didn't appear. The Up was stuck in this state for a good while before rebooting again, but this time the SETUP text appeared. The Up then got stuck again.

    Removing CMOS battery did nothing, nor did using a battery from a working Up.

    I inserted a BIOS update USB stick and did the whole thing again, pressing F7 a few times and waited for the 10-15 mins the Up took to get past the logo screen. The boot menu appeared, I chose the USB stick, the Up booted back to the logo screen, but this time the "SETUP" text appeared. I repeated the procedure and successfully booted to the USB stick's EFI shell.

    I updated the BIOS from UPC1BMOS to UPC1DM11. The same hang happened.

    Then I copied the BIOS settings over from another Upboard using AfuEfix64.efi. This didn't fix the issue, although the new BIOS settings clearly were loaded as the LEDs turned on.

    I booted to a Clonezilla live system from USB. The boot into Clonezilla took about as long as the boot through the BIOS logo screen. There I made the following observations:

    • Kernel logs show: mmcblk0: error -110 sending stop command, original cmd response 0x2000900, card status 0x2400900 among other errors. See kern.log
    • lsblk -b lists the eMMC, but shows its size as 8192 bytes
    • fdisk -l takes a very long time to complete and does not list the eMMC
    • wipefs /dev/mmcblk0 takes a few seconds to run, but completes without errora
    • parted /dev/mmcblk0 mklabel gpt takes a long time to run and returns with: "error: Device too small for GPT"

    My guess is: Broken eMMC, RMA it?

    kern.log 467.4K
  • DCleriDCleri Administrator, AAEON Posts: 699 admin

    Hi Jesse,

    Yes I think you should proceed for RMA

  • gillesgilles New Member Posts: 2

    Hi,
    I have the same problem
    Should i proceed for RMA too ? I have serial cable but no information during boot...

  • DCleriDCleri Administrator, AAEON Posts: 699 admin

    Have you tried all the options described in this topic, including the suggestions in our wiki?

    https://wiki.up-community.org/FAQs#Not_Booting_or_Powering_up

    If you did and the board does not work, you should apply for RMA

  • gillesgilles New Member Posts: 2

    Hi,
    i did it, the board sn C19418996 does not work. My reseller send me free ( very good reseller ) another board with sn C19418995, very closed sn number. From this reseller i have bought three other board sn C19419001, sn C19419062, and another without serial number and with BIOS UPC1BM0S 06/04/2016 . I install ubuntu 16.04.6 on last board sn C19418995, starting ok. Reboot same problem no way now its blackscreen no logo screen, may be a component serial bug ? I do the same work with other boards 9001, 9062 and nosn, no problem they work perfectly. I don't understand.

Sign In or Register to comment.