Have blue power light, no HDMI, no ethernet status lights

I have used up board to make ROV. At first, it works normally, can ping between ground control and the vehicle that uses intel up board but after I will bring it out to improve the code by I have plugged the screen through HDMI to check the code easily but it shows no signal. Normally, it can be done. When I try to ping to the board, the board has no reply go back. I tried checking the USB by plugging in the mouse but no power to my mouse. And no ethernet status lights. But blue power light comes on and Fan spins.
I tried following this link but nothing changed.

https://forum.up-community.org/discussion/908/fix-wont-boot-no-hdmi

Does anyone know what is causing this or is there a way to fix it? I'm sure no water gets into this board. I have tested it many times, no problem. But there was a problem in this round that made it impossible to continue the work.

Comments

  • DCleri
    DCleri Administrator, AAEON Posts: 1,208 admin

    if the ROV is powered by battery, the battery must use a DC/DC converter and stabiliser to provide a continuous and stable voltage.

    If not, that can damage your board.

    Do you have any other details of your system?