FIX: wont boot, no HDMI

Options
This is a success story for others who think they may have fried their UP board.
Scenario:
While connecting my board to my project, it got power-cycled a lot and potentially shorted on the metal bits and pieces that I have floating around.
My board would seemingly not boot. There was no output whatsoever on the HDMI port for any screen I connected to it. No connected peripherals would light up like they were getting power. The board's blue power light worked, but beside from that, it seemed completely dead. The other hardware connected to my project seemed okay. Yes, I power cycled the board and let it sit.
Fix:
Press and hold the power button on the UP board for at least 30 seconds. The blue power LED should turn off. If you put your ear to the board, you should hear the high pitched whining stop. At this point, you have to unplug your board from power and then reconnect it. Just like that, the board boots. Magic.

Comments

  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Options
    Thanks very much for sharing that tip!

    It sounds a bit like a "flea power" issue, as described here:
    http://accatech.com/flea-power-drain/

    Although that I see you fixed it by holding the power button with the power supply was still connected, so perhaps it isn't exactly the same. In any case, that's great that we have some things to try now if others encounter the same symptoms.
  • Pierre Laurent
    Pierre Laurent New Member Posts: 6
    Options
    I got similar boot problems (mainly around failed usb discovery which only worked randomly after power plug-out/plug-in), they were solved by using a 4A power supply instead of 3A power supply.

    Maybe the connected devices are draining too much power at boot time ?
    Can you describe which devices are connected to your board ? keyboard/mouse/hdmi/ssd drive/wifi dongle/usb-powered barbecue/hats ...... :-) ???
  • Keith
    Keith New Member Posts: 3
    Options
    The problem I described occurred with only HDMI connected. I tried with and without keyboard and screen and my problem persisted until i held the power button for as long as i did and heard the board go silent.
  • Pierre Laurent
    Pierre Laurent New Member Posts: 6
    Options
    I remember I could not use my first HDMI cable, and it worked with a spare one.
    I have also seen sporadic long boot times , around 2 minutes, but I didn't try pressing the reset button for a while as you mention.

    Did you try a different HDMI cable ? And wait an excessively unreasonable long time ?
  • Keith
    Keith New Member Posts: 3
    Options
    I tried 2 HDMI cables, both of which I verified as working with another device (and were verified as working with the UP board after my fix).
    I did wait an excessive amount of time (5 minutes).
  • Chris Botha
    Chris Botha New Member Posts: 48
    Options
    I had severe issues getting mine to boot last night. I found a tip about powering down and removing battery for 15 minutes. It worked after that.
Privacy Policy