Low Ethernet Speeds

Hello, I have an UP squared (Celeron & 2G Ram w/ 5.2 BIOS) that I have been having issues getting gigabit speeds on either of the ethernet NICs. Speed tops out at around 700mbps on both speedtest-cli and the browser version at https://www.speedtest.net/ . Ive tried both ubuntu 20 ( w/ default kernel, upboard kernel, and also ubuntu 20 edge kernel both with the default r8169 kernel module and then r8168-dkms) and fedora 34 and at multiple location on the network. A laptop can always get up into the 900's mbps when plugged into the same ports that Ive tried with the UP Squared. Originally I thought it was something with the power management system in Linux but I have disabled upowerd in systemd and also boot to the command line (so desktop power management wouldnt come into play) without any noticeable changes. Any help would be much appreciated

Comments

  • txDood
    txDood New Member Posts: 2

    Update on this, I have tried a USB 3 ethernet adapter and was able to get up to 850mbps. Im starting to wondering if I have a bad unit or if this is due to the limits of the hardware

  • rogertsai(AAEON)
    rogertsai(AAEON) New Member Posts: 303 ✭✭✭
    edited July 13

    @txDood
    You can check whether the LAN speed in your UP^2 show "1000Mbps" Ethernet connection.
    If your UP^2 is hardwired to your hub/router, check the ethernet cable, or try using a different ethernet cable to check this issue.