UPsquared Robomaker motion is jerky

I bring up Ubuntu 18.04 preloaded image. I run the ROS2 example using:
ros2 launch hamster_driver ros2_camera_and_driver.launch.py

I launch rqt and set the speed value in ackermann_cmd topic to 0.01.
The movement is not smooth but instead it moves in bursts. It moves for a second, stops and then moves for a second, stop and so on.

I don't know how to debug this. I am suspecting the motor. I don't want to order another prokit that costs $1800 just because the motor is faulty. Can someone please help me debug and identify the cause for this? Also, can I please get the information on the model of the DC motor that is used?

PS: it would be really amazing, if the motor control board on the prokit is available for purchase separately and the details of the models of other components were specified in the spec document.

Comments

  • yakirari
    yakirari New Member Posts: 1

    Hi spoluri.
    I do not think this is a motor issue.
    1) The value 0.01 is very small. The PID will have a hard time to keep such a velocity. Try with values > 0.5. If you are interested in keeping low speed the source code of the LLC firmware can be shared with you and flushed on the board (using FTDI) to handle it
    2) The LLC (control board) commands should be sent at a rate of 10Hz. Below that the watchdog might kick in and cause the erratic behaviour you describe.
    3) The LLC can be purchased separately. Feel free to contact us at [email protected]
    Best,

  • spoluri
    spoluri New Member Posts: 5

    Thank you so much! I tried both the modifications of increasing the speed and increasing the rate. Runs smooth now!

Sign In or Register to comment.