OTG USB gadget not detected

samhsamh New Member Posts: 4
edited December 2020 in UP Squared Troubleshooting

The device (up squared) has a freshly installed Ubuntu 18.04, with the latest BIOS (UPA1AM52) and updated kernel: Linux ubuntu 5.4.0-1-generic #0~upboard2-Ubuntu

I'm unable to get any of the usb gadget classes to work, despite following the instructions (in the wiki) to the letter. The USB device does not get recognized by the host (usbview.exe in win10 shows ConnectionStatus: NoDeviceConnected)

What EXACT steps does one need to take to make any of the classes demonstrate that they work? So far I haven't succeeded with any one of them.

When trying the g_mass_storage example, dmesg | tail returns this:
g_mass_storage gadget: Mass Storage Gadget: version: 2009/09/11
g_mass_storage gadget: userspace failed to provide iSerialNumber
g_mass_storage gadget: g_mass_storage ready

I have also tried the configfs approach, but that doesn't work either. I use the OTG USB cable as provided by Up. Host device is Windows 10, but also tried a Ubuntu host with similarily negative outcome.

Comments

Sign In or Register to comment.