Stability issues, some specific code on the EMMC? Whiping EMMC helped

gvy
gvy New Member Posts: 9

Hi, we have had issues with 2 fresh UP Squared boards from Mouser.
When we got them we upgraded the bios to the newest version but trying to install Debian or Ubuntu or even Windows 10 resulted in cpu errors and very unstable behaviour.
On one board we had some initial locks, reboots but after managing to install Debian 10 it actually works with bios 4.6 installed.
The other board we send back because we thought it had HW faults and we ordered a new one some weeks ago. This one had the same problem. However, strange thing was that after I used the Windows 10 installer and wiped the whole EMMC disk and removed all partitions it seemed Windows 10 updated/changed the UEFI code because after a reboot the boot logo changed.
After that i decided to give Debian another try (i never wanted Win10, just tried it to see if that would work) and I could install Debian without any cpu locks or reboots and the system has been running for a month without any problems.

So is there some code/bootloader running on default that could get faulty or something like that? Also, you seem to support only a few Linux distributions and specific kernels but why is that? Shouldnt it work (and in my case after whiping and removing all partitions it does) with any Linux distro/kernel?
Also, could this explain the other stability issues that have been reported online?

Comments

  • DCleri
    DCleri Administrator, AAEON Posts: 1,189 admin

    The instability you are mentioning is really strange and different from other reported in the forum.

    When you install the OS for the first time it is advisable to re-partition the disk completely, wiping the partition table (you can easily do it with Windows and Debian, Ubuntu has an option that it does automatically).

    Also which PSU are you using with UP Squared?

    Regarding the support, the reason is because we need to add specific changes to enable features that are not included in the mainline kernel, which requires extra work of integration and validation.
    For this reason we officially support Ubuntu and Yocto only.

    You can run any kernel/distribution you want (the newer the better), but without our custom kernel, you will lack some functionalities, in particular the 40pin header I/O.

  • gvy
    gvy New Member Posts: 9

    I am using the advised 6A power supply EP-PS5V6A65WUPS. Clear on the 40pin I/O etc, i forgot about that since i am not using it.

    I started with a Clonezilla live image from USB, that gave 'CPU core .. hang' or something like that error. Same with Debian and Ubuntu sticks. Before any gui comes up it hangs at boot.
    Then, i tried installing Win10 with a mediacreation tool image and got blue screen while rebooting after installation, installation itself went fine. Tried resorting defaults in the bios (both with and without password) but no improvements
    So my last resort was wiping all partitions on the disk (3 or 4 fresh from factory as i remember correctly) and start over with a Debian netboot image and suddenly it worked. Hence my thought that something on the eMMC was doing something. Or that Linux tried some microcode or incorrect CPU settings or something like that.
    Now that i got it up and running it works a treat.

    One additional question: how to enable UEFI secure boot? I tried enabling it in the bios and then running a Debian 10 installer but that didnt work so now I am running with secure boot off.