There is no wifi after .hddimg is installed

likkulikku New Member Posts: 3
edited February 18 in UP Squared Linux

My device is https://www.aaeon.com/en/p/iot-gateway-ups-gws01 and I follow https://github.com/AAEONAEU-SW/meta-up-board/tree/sumo to build a .hddimg.
However, there is no wifi interface in ifconfig and "iwlist wlan0 scan" is not working.

=======================================================
[email protected]:~# ifconfig
docker0 Link encap:Ethernet HWaddr 02:42:AA:0F:53:0C
inet addr:172.17.0.1 Bcast:172.17.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

enp2s0 Link encap:Ethernet HWaddr 00:07:32:58:DB:91
inet addr:172.23.115.28 Bcast:172.23.115.255 Mask:255.255.254.0
inet6 addr: fe80::207:32ff:fe58:db91/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1359 errors:0 dropped:65 overruns:0 frame:0
TX packets:103 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:112580 (109.9 KiB) TX bytes:15523 (15.1 KiB)

enp3s0 Link encap:Ethernet HWaddr 00:07:32:58:DB:92
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:86 errors:0 dropped:0 overruns:0 frame:0
TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6630 (6.4 KiB) TX bytes:6630 (6.4 KiB)

[email protected]:~# rfkill list all
0: hci0: bluetooth
Soft blocked: yes

Hard blocked: no

build command:
TEMPLATECONF=meta-up-board/conf source oe-init-build-env
MACHINE=up-squared bitbake upboard-image-base

Thanks.

Best Answers

Answers

  • DCleriDCleri Administrator, AAEON Posts: 1,052 admin

    the wifi on that product is optional.

    Are you sure you got the one with the WiFi module installed?

  • likkulikku New Member Posts: 3

    Hi DCleri,

    Thanks for your reply.
    I use a bootable USB stick to boot "ubuntu" for USB and there is a wifi interface (wlp4s0) in ifconfig.

    =============================================================
    [email protected]:~$ ifconfig
    enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 172.23.115.37 netmask 255.255.254.0 broadcast 172.23.115.255
    inet6 fe80::1ebd:6bf0:a639:4663 prefixlen 64 scopeid 0x20
    ether 00:07:32:58:db:91 txqueuelen 1000 (Ethernet)
    RX packets 5431 bytes 2773744 (2.7 MB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 1325 bytes 122834 (122.8 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    enp3s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether 00:07:32:58:db:92 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10
    loop txqueuelen 1000 (Local Loopback)
    RX packets 174 bytes 14744 (14.7 KB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 174 bytes 14744 (14.7 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    wlp4s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
    ether f8:a2:d6:76:6d:99 txqueuelen 1000 (Ethernet)
    RX packets 0 bytes 0 (0.0 B)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    [email protected]:~$ iwlist wlp4s0 scan
    wlp4s0 No scan results

    [email protected]:~$ iwconfig
    lo no wireless extensions.

    enp2s0 no wireless extensions.

    enp3s0 no wireless extensions.

    wlp4s0 IEEE 802.11 ESSID:off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
    Retry short limit:7 RTS thr:off Fragment thr:off

    Power Management:on

    Thanks,

    Cheers,
    Likku

  • DCleriDCleri Administrator, AAEON Posts: 1,052 admin

    can you please identify the type of wifi card using dmesg?

  • likkulikku New Member Posts: 3
    edited February 20

    Hi DCleri,

    Thanks for your help.
    The dmesg of yocto and ubuntu are attached.
    In ubuntu_demesg.txt, the log listed below may be related to wifi.

    [ 32.303272] ath10k_pci 0000:04:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 11ad:0808
    [ 32.303277] ath10k_pci 0000:04:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
    [ 32.304069] ath10k_pci 0000:04:00.0: firmware ver WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb

    BTW, the model of my device is "UPS-VKIT01-GWS01X7-A20-0464".

    Cheers,
    Likku

  • DCleriDCleri Administrator, AAEON Posts: 1,052 admin

    Thanks @likku

    So the WiFi is working correctly on Ubuntu? Can you confirm?

    We will review why with the Yocto image the WiFi firmware is not loaded and we will come back to you asap

Sign In or Register to comment.