Up Squared board and UPS and wide range DC-in HAT

claytongclaytong New Member Posts: 3

I purchased an Up Squared board and the UPS and wide range DC-in HAT from the Up store (https://up-shop.org/up-peripherals/112-ups-and-wide-range-dc-in-hat.html). I've been unable to find any documentation or software from the Up pages on the UPS, but it appears to be a rebranded S.USV (https://olmatic.de/en/products/susv/). I've installed Ubuntu on the Up Squared board, followed the instructions on the wiki to load the Up specific kernel and added the upboard-extras package, and downloaded and installed the software from olmatic that claims to be specifically for the Up Squared board, but the monitoring software doesn't work and the lights on the UPS board just flash in the "initializing" state. Has anyone ever successfully used the UPS board on an Up Squared board? If so, can you offer any suggestions?

Comments

  • olmaticolmatic New Member Posts: 2

    Hi,

    Could you please provide the following further information to analyze the problematic in detail:

    • Which S.USV soft- and firmware versions do you exactly use?
    • Is it possible to send a status query via sudo ./susv -status
    • Please also send us an excerpt of susv.cfg - it is located in the directory** /opt/susvd**
    • Which message you receive when you execute the following command sudo ./susvd -start or sudo ./susvd- restart
    • Please also send us an extract from following command sudo i2cdetect -r -y 1

    Thank you in advance for your support.

  • claytongclaytong New Member Posts: 3

    Thank you for your help.

    • I downloaded and installed susvd-en-2.40-systemd-up2.deb, and downloaded susv_fw_26_up2.hex. I'm not able to confirm the firmware version, because I'm not able to communicate with the board.
    • Executing sudo /opt/susvd/susv -status gives "S.USV Daemon running... PID: 828"
    • I can get a copy of /opt/susvd/susv.cfg (the system isn't on the net at the moment, so I can't post it directly), but I've never edited that file so it should be exactly what the package installed.
    • Executing sudo /opt/susvd/susvd -restart gives "S.USV Daemon stopped!" followed by "S.USB Daemon started..". Looking in /var/log/susvd.log I see "SUSVD: Entering Daemon SUSV.", "SUSVD: Set GPIO27 to output", "SUSVD: Unable to select I2C device"
    • Executing sudo i2cdetect -r -y 1 lists a blank array of addresses with no devices listed
  • claytongclaytong New Member Posts: 3

    The information above is dated - I was having trouble logging in to post because of some corporate IT issues. After basically giving up on the UPS functionality of the board and moving on to other things, I noticed after rebooting the Up squared board yet again (it had been rebooted many times after installing the board and software) that the leds on the board were showing a different pattern. The log still reported "Unable to select I2C device", but when I ran i2cdetect -r -y 1 I got a different result than before that showed the i2c device mentioned in the manual. After some more debugging I realized that the /opt/susvd/susv.cfg file had an entry that pointed to i2c bus 6, but the i2cdetect command is scanning bus 1. I changed the susv.cfg file to point to bus 1 and restarted, and the software now sees the device.

    I can now succusfully run susv -status, so I can say my board is hardware version 2.2, with firmware version 2.51. I'm guessing I should attempt the firmware update procedure in the manual? (Assuming susv_fw_26_up2.hex is version 2.60?)

    I'm uncomfortable with the board / driver / kernel somehow magically fixing itself after some arbitrary reboot. The Up Squared board isn't connected to a network at all, so there's no way a software update occurred in the background, and the system had been rebooted many times (some of them including hard power cycles) with no change before it suddenly started presenting the I2C device. It's been rebooted several times afterwards and it's still working...

  • olmaticolmatic New Member Posts: 2

    Hi,

    Sorry for our late reply - unfortunately the notification didn't work.

    It is strongly recommended to update the i2c bus parameter in the susv config file for coressponding i2c communication. Once this is updated, this should work without any further problems - insofar the UP² board works on the same i2c bus.

    Also we recommend to always use the actual firmware update - actually 2.60

Sign In or Register to comment.