I2C clock speed settings

pinyopinyo New Member Posts: 2

Hi All!
I have an issue with the clock speed settings of the I2C bus. I would like to use the i2c-1 peripheral (pin3 and pin5 on the 40 pin header) with standard mode (100 kHz). I set the module to ACPI mode and the speed settings is 100 kHz in the BIOS. The frequency of the SCL pin is 625 kHz which I measured with an oscilloscope and it doesn't depend on the BIOS speed settings. I compared the HKLM/HARDWARE/ACPI registry key with the two different speed settings (100 kHz and 400 kHz). The keys were equal.
I found similar issues under linux:
https://forum.up-community.org/discussion/3943/up2-how-to-select-i2c-speed-mode
https://forum.up-community.org/discussion/3850/up-board-ubuntu-18-04-i2c-speed-select

Current configuration:
BIOS: UPC1DM17
OS image ID: Windows
OS: Windows10 Pro 1903
I used aaeonEAPI.dll library with .NET Core 3 (GPIO and PWM modules work fine)

Best regards

Sign In or Register to comment.