UP Board UBUNTU 18.04 - I2C speed select

lz1mszlz1msz New Member Posts: 1

We use UP board with standard UBUNTU 18.04 installation and then custom kernel update, according to the instruction:
https://wiki.up-community.org/Ubuntu

We use I2C0 (PIN 27 and 28) to communicate with ATECC508A. It requires 100KHz operation and not possible to use with 400KHz (actually possible up to 1M, but the Wake-up procedure will not work using the i2c driver). We need to setup the I2C speed to 100KHz. We did that trough the BIOS and the speed remained 400KHz. Do you know any way to run the I2C with 100KHz?

Comments

  • AustinLAustinL New Member Posts: 3

    Did you ever solve this? I have the same problem with my UPCORE. However i have the latest BIOS they currently offer and it does not give me the option to change the speed. How did you change the speed in the BIOS.

  • ccaldeccalde New Member Posts: 348 admin

    Hi,

    Thank you for the information about the speed issue.
    We will try to replicate the problem locally with the latest BIOS to get a solution as soon as possible.

  • ccaldeccalde New Member Posts: 348 admin

    Hi @lz1msz ,

    Could you tell us the BIOS version are you using?
    Also, why don't use the i2c-5 for SDA and SCL (3 and 5 pins)? Did you try?

  • mdostiemdostie New Member Posts: 3

    In our case, changing the I2C mode from ACPI to PCI made it. It's in the BIOS menu. And we use i2c-5 (pins 3, 5) along with the BIOS UPC1DM15 because we are unable to upgrade to UPC1DM17.

Sign In or Register to comment.