How do you change I2C frequency from fast mode(400khz) to standard mode (100Khz) for I2C0 (i2c-0)?

AustinLAustinL New Member Posts: 4

I am using Ubuntu 18 with the latest kernel installed and the latest BIOS

Kernel:
Linux easyrassor 4.15.0-37-generic #40~upboard04-Ubuntu SMP Thu Feb 14 13:49:37 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

BIOS:
UCR1BM18

I am using I2C0 pins 73&75. I have probed this with an oscilloscope and the frequency is clearly 333Khz. I believe that the I2C bus is in Fast mode. I need it to be in Standard mode.
My device works perfectly fine on a Raspberry pi @ 100Khz.
There is no option in BIOS to change the speed.

Please help!!

Tagged:

Answers

  • DCleriDCleri Administrator, AAEON Posts: 805 admin

    Hi @AustinL

    Similarly to how you do it on other UP Platforms, you can find the settings in the BIOS under Advanced, HAT Config.

    There you can see 2 I2C ports where you can select the speed to standard if you want to run at 100Khz.

    Please make sure you have the latest kernel installed from our PPA

  • AustinLAustinL New Member Posts: 4

    Thank you for replying!

    I have the latest kernel and BIOS, I have installed upboard-extras and enabled user support.
    Kernel: Linux easyrassor 4.15.0-37-generic #40~upboard04-Ubuntu SMP Thu Feb 14 13:49:37 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    BIOS: UCR1BM18

    I do not have the the HAT Config under Advanced for my any of my Up Core Boards.
    I have several Up Boards, Up Cores and Up Squared's as well.
    On the UP BOARD I can see HAT Config and I can change the I2C Speed
    On the UP SQUARED I can see the HAT Config but there is NO option to change I2C Speed.
    On the UP CORE (Our primary concern) I cannot see the HAT Config option.

    Is there any reason why I am not seeing the HAT Config on any of my UP CORE Boards?

Sign In or Register to comment.