[SOLVED] Disable graphical interface.

SilSil New Member Posts: 29 ✭✭
edited July 2019 in UP Squared Linux

Dear all,

does someone of you know how to totally disable the graphical interface and start the system only in the terminal mode?

Thanks.

Silvano

Eng. Silvano Bertoldo, PhD

Comments

  • snuhgsnuhg New Member Posts: 14

    Try this as sudo user (and perhaps test it first in a non-critical set-up):

    systemctl get-default
    This should show you the current setting, i.e. graphical.target

    Then confirm that the terminal mode is available (it's called multi-user.target) in the list of target files:
    systemctl list-unit-files --type=target

    If you have multi-user.target in the list of target files you can proceed with setting it as the new default target:
    systemctl set-default multi-user.target
    If you now reboot the system it will boot into terminal mode, i.e. it will give you a shell with login prompt instead of the desktop

    You can of course get back to the graphical mode by
    systemctl set-default graphical.target and reboot

  • SilSil New Member Posts: 29 ✭✭

    Ok, thanks!
    I'll try it!

    Silvano

    Eng. Silvano Bertoldo, PhD

Sign In or Register to comment.