GNU Grub prompt cannot get my UP squared to boot

    I'm running Ubilinux with all the latest updates on and recently when I reboot I'm
    presented with the Grub prompt. I've installed my ubilinux when I got my Up Squared
    over a year and a half ago now and it's been running great up until now. I'm using
    the EMMC storage for the root partition and /boot, and a msata for my /home.

    I can boot the system using a SuperGrub USB and Detecting my OS. I then select
    /boot/vmlinuz-4.15.0-3-amd64 (hd2,gpt2) and it boots. I don't want to have to do this
    every time though.

    I've updated my BIOs to try and fix the problem from 1.8 to 4.0. I've also tried
    a 'sudo grub-install' and 'sudo update-grub' when booted into my system, but this
    didn't fix the grub menu either. I tried 'sudo grub-install --removable', still
    the same problem happens. I also tried point grub install to my device
    'sudo grub-install /dev/mmcblk0'.

    Originally I was getting this error when doing a grub-install
    : Could not prepare Boot variable: No space left on device
    After upgrading the BIOs this has since gone away and now grub-install will run
    successfully but I still cannot boot.

    What am I doing wrong here?
    How can I get my Grub menu back and working?
    Is there a way to boot from the Grub prompt and would this help diagnose and fix
    the problem?
Tagged:
Sign In or Register to comment.