Wifi Dongle - iwconfig - Operation not permitted

MatAffMatAff New Member Posts: 18 ✭✭

I'm trying to use a wifi dongle to connect my Up-Board to my network. But I'm getting stuck. I'm running ubilinux. This is what I've done so far.

When I run:
sudo ifconfig -a

The dongle shows up as:

wlx503eaa88648a: flags=4098<BROADCAST,MULTICAST>  mtu 1500
    ether 50:3e:aa:88:64:8a  txqueuelen 1000  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 0  bytes 0 (0.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

When I run:
lsusb

The device shows up as:
Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

I installed wireless tool using:
sudo apt-get install wireless-tools

I tried to add my network using:
sudo iwconfig wlx503eaa88648a essid MyNetworkName key s:MyNetworkPassword

But this results in:
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device wlx503eaa88648a ; Operation not permitted.

Any suggestions would be greatly appreciated!

Tagged:

Comments

  • MatAffMatAff New Member Posts: 18 ✭✭

    I managed to get this running. For reference, this is what I did to fix it. (Apologies if I missed a step.) First I ran the following:

    sudo ifconfig # Shows only active devices
    sudo ifconfig -a # Shows all devices
    

    The wifi dongle only showed up with the second one, which altered me to the fact that I needed to enable the device which I did with:

    sudo ifconfig [device reference] up
    

    In my case the device reference starts with wlx. Next I added the network info to the file /etc/wpa_supplicant.conf

    network={
        ssid="[networkName]"
        psk="[password]"
    }
    

    I started the WPA connection with:

    sudo wpa_supplicant -B -i  [device reference] -c /etc/wpa_supplicant.conf -D wext
    

    When I ran 'sudo route -t' I noticed there was no default gateway specified, which I added using (not sure both are needed):

    sudo /sbin/ifconfig  [device reference] [desired ip] netmask 255.255.255.0 broadcast 192.168.1.255
    sudo route add default gw [router ip] [device reference]
    

    The desired ip can be chosen. My ethernet ip is usually 10.0.0.19 so I choose 10.0.0.29, as I find it easy to remember.

    Finally I ping my router to see if the connection is established:

    sudo ping -c 3 [router ip]
    

    For the moment I've set this up as a script that runs after boot.

    Here are some threads that I found useful:

    https://askubuntu.com/questions/138472/how-do-i-connect-to-a-wpa-wifi-network-using-the-command-line

    https://ubuntuforums.org/showthread.php?t=2215975

    https://raspberrypi.stackexchange.com/questions/14101/connect-network-is-unreachable-on-a-working-connected-wlan0-interface

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 266 admin

    Hi @MatAff ,

    Thank you so much for sharing the info :)

Sign In or Register to comment.