New Up Board No HDMI Display Signal :(

NyashaNyasha New Member Posts: 2

Hi

I got the UP board and the official power 5V supply yesterday but cannot get anything to display via HDMI. I've tried a number of the solutions here without any effect.

  • It's a new UP board, came with the accompanying power supply
  • I I've plugged into a number of different displays. It displayed once (showed first step of Ubuntu 16 installation step.
    *I have tried 4 different displays and switched cables as well. No luck so far

  • I have also attempted the steps mentioned here (disconnecting the CMOS battery) : https://wiki.up-community.org/Not-Booting_or_Powering-Up

  • I have tried the settings above with and without the boot USB connected
  • I have also tried to boot without the HDMI cable connected for the first few seconds

I am not sure what I am doing wrong. The system powers up, keyboard Caps light toggles, boot USB shows some activity (via its own light), Blue LED light on board is on as well.

I'd be happy to try any recommended troubleshooting steps if anyone knows a working solution.

Thanks for any advice you can offer.

Comments

  • DCleriDCleri Administrator, AAEON Posts: 1,014 admin

    Hi @Nyasha

    It is strange that the screen displayed once the Ubuntu installation, usually if it is DOA you won't be able to see anything on the screen.

    I would suggest to try again the steps to remove the cmos battery (try for longer time to leave the system completely disconnected and without battery). If still does not work you should fill a RMA request from the shop.

  • Sam VSam V New Member Posts: 7

    Hello,
    I have been having the same issue. I have not used the board for a long time, and it was sitting idle. I powered it up recently and now nothing shows up on the HDMI output. I use my Rapsberry Pi on the HDMI screen, so I know its not faulty. There is absolutely no acitivity when I connect and powerup the UP board. The fan and LED on the board are the only things working. Has the board gone bad?

  • Sam VSam V New Member Posts: 7

    @Nyasha - Have you been able to resolve your issue. I am concerned if I will have to bin this board! I bought it a couple of years back - so looks like warranty is also out.

  • NyashaNyasha New Member Posts: 2

    @Sam V @DCleri

    Hey. sorry for not responding sooner. I got frustrated and then moved to an Nvidia TX2 because I could not find any solution. I just tried the board again. Same dead end. I would really appreciate the help if someone can walk me thru a solution for this.

    All I have is a steady blue light and a fan running. Not sure what else to try.

  • Sam VSam V New Member Posts: 7

    Hi @Nyasha - I know its frustrating. The UP-Board community is not that active - and to add to that - there is little or no response from AAEON. It was not a wise choice for me to pickup the UP-Board. Will never make this mistake again!

    I was able to partially resolve the issue. There were my steps - hope they help you.
    1. Manually power-down the board by holding power button for 10 seconds or so.
    2. Disconnect RTC battery for about 10 minutes (may be longer sometimes) and let CMOS clear out. I did this cycle 3-4 times.
    3. Power on the board and press DEL key to get into BIOS settings
    4. Navigate to Chipset -> North Bridge and search around for option for Panel support. If you are using a TFT/IPS or eDP display, you will have to enable this option and select a HDMI resolution.
    5. Note that some monitor work with my Intel NUC but did not work with UP board. None of my IPS/eDP panels work with UP-board. So I had to finally buy a new HDMI IPS LCD panel that worked with UP board.

    Good luck!

Sign In or Register to comment.