UP Squared not booting up, only solid blue led

Hi I am using Up Squared Celron 2GB and 32GB.
First time when i opened, it was working fine but after shutting down it doesn't respond.

It doesn't show anything, the only thing i see is the solid blue led. I've tried re-flashing but it doesn't react only. I am not able to find any useful thread on community also.

Could anyone please help me out with trouble shooting of this issue ? or suggest what should i do ?

Comments

  • DCleriDCleri Posts: 524Administrator, Emutex admin

    Hi Suryender,

    What power supply are you using?

    Please try to unplug the board from any cable and also remove the RTC battery.
    After 5 to 10 minutes, reconnect the RTC battery, then add your USB stick with the OS installer and the other cables, then plug the power cable.

  • suryendersuryender Posts: 5New Member

    Hi, thank you for the response.
    I’ve grove IoT development kit, it comes with [email protected] power supply in the box. I am using the same.
    Initially the board was working fine, next time it didn’t turn up shows only solid blue led, I’ve already tried removing the RTC battery, it didn’t work.
    I think for re-flashing also it should show something, it doesn’t show anything on screen, something wrong with boot loader or bios, I’ve no clue what’s wrong. Please suggest.

  • suryendersuryender Posts: 5New Member

    @DCleri said:
    Hi Suryender,

    What power supply are you using?

    Please try to unplug the board from any cable and also remove the RTC battery.
    After 5 to 10 minutes, reconnect the RTC battery, then add your USB stick with the OS installer and the other cables, then plug the power cable.

    Hi, I've tried as per the procedure suggested by but no success it still dead, no response. could you please help what to do ?

  • DCleriDCleri Posts: 524Administrator, Emutex admin

    You can try a different screen or cable just in case but before that, you can try to use this image to reflash the Operating System:
    https://downloads.up-community.org/download/up-squared-iot-grove-development-kit-ubuntu-16-04-server-image/

    follow the procedure in the description to flash the image in the "attached files" tab.

    If at the end of the procedure it does not work, please file an RMA from your account on the UP-shop. You can point this topic to describe the failure.

Sign In or Register to comment.