IPU4 unable to disable secure mode

akazminakazmin Posts: 4New Member
edited July 12 in UP board BIOS

Hello,

I have the following setup:
UP Squared with the latest (UPA1AM33) BIOS and Yocto with the intel-lts 4.14 kernel with integrated IPU4 driver.

I enabled IPU4 device from BIOS via Main -> CRB Setup -> CRB Chipset -> Uncore Configuration -> IPU Enable option (Secure Boot was disabled). After that I tried to load linux kernel with the IPU4 secure mode disabled option. I got the following dmesg output:

[ 1.874221] intel-ipu4 0000:00:03.0: enabling device (0000 -> 0002)
[ 1.874368] intel-ipu4 0000:00:03.0: Device 0x5a88 (rev: 0xb)
[ 1.874416] intel-ipu4 0000:00:03.0: physical base address 0x90000000
[ 1.874417] intel-ipu4 0000:00:03.0: mapped as: 0xffffb0f442000000
[ 1.875724] intel-ipu4 0000:00:03.0: update security control register failed
[ 1.883562] intel-ipu4 0000:00:03.0: Unable to set secure mode!
[ 1.883564] intel-ipu4 0000:00:03.0: IPU in secure mode

Also, I tried to disable IPU4 secure mode manually from the EFI shell using mm write to the IPU4 BAR0 Security Ctl register (offset 0x300) according to the driver flow. But it looks like this register is RO.

Is the unsecure mode is supported for the IPU4 at the current moment? Should I use any other option in BIOS to enable IPU4 Security Ctl register writes?

Best regards,
Andrey

Comments

  • T1000T1000 Posts: 5New Member

    There is no "CRB Setup" in the UP Board, not that I can find. You might want to try the appropriate UP squared forums for help rather than the UP Board forums. However, for UP Board, I too was wanting to disable secure boot and my searches through the forum found that this can not be done. Having secure boot and EFI seems compulsory for the UP series.

  • DCleriDCleri Posts: 508Administrator, Emutex admin
This discussion has been closed.