Up squared IPU4 disable secure mode

akazminakazmin New Member Posts: 4

Hello,

I have the following setup:
UP Squared with the latest (UPA1AM33) BIOS and Yocto with the intel-lts 4.14 kernel with integrated IPU4 driver.

I enabled IPU4 device from BIOS via Main -> CRB Setup -> CRB Chipset -> Uncore Configuration -> IPU Enable option (Secure Boot was disabled). After that I tried to load linux kernel with the IPU4 secure mode disabled option. I got the following dmesg output:

[ 1.874221] intel-ipu4 0000:00:03.0: enabling device (0000 -> 0002)
[ 1.874368] intel-ipu4 0000:00:03.0: Device 0x5a88 (rev: 0xb)
[ 1.874416] intel-ipu4 0000:00:03.0: physical base address 0x90000000
[ 1.874417] intel-ipu4 0000:00:03.0: mapped as: 0xffffb0f442000000
[ 1.875724] intel-ipu4 0000:00:03.0: update security control register failed
[ 1.883562] intel-ipu4 0000:00:03.0: Unable to set secure mode!
[ 1.883564] intel-ipu4 0000:00:03.0: IPU in secure mode

Also, I tried to disable IPU4 secure mode manually from the EFI shell using mm write to the IPU4 BAR0 Security Ctl register (offset 0x300) according to the driver flow. But it looks like this register is RO.

Is the unsecure mode is supported for the IPU4 at the current moment? Should I use any other option in BIOS to enable IPU4 Security Ctl register writes?

Best regards,
Andrey

Comments

  • akazminakazmin New Member Posts: 4

    I'm not sure that disabling secure mode is good idea, but the driver fails to load IPU4 firmware in secure mode. I think, it's kind of CSE interaction issue, because as I understand CSE is involved in secure mode FW loading and CSE doesn't act as the driver expects.

  • DCleriDCleri Administrator, AAEON Posts: 731 admin

    Hello Akazmin,

    The IPU4 feature has not being tested yet as the first kernel to fully support it is 4.14.

    Unfortunately the current supported kernel is 4.9 for Debian and Yocto and 4.10 for Ubuntu.
    We plan to upgrade the supported to kernel 4.14 later this year.

  • akazminakazmin New Member Posts: 4

    Hello DCleri,

    Thank you for the answer!

    Am I right that IPU4 is supported and tested for Windows IoT with the latest BIOS?

    Best regards,
    Andrey

  • DCleriDCleri Administrator, AAEON Posts: 731 admin

    Yes you are right, it is already supported in Win10 IoT Ent, LTSB, 1607 with BIOS UPA1AM33

Sign In or Register to comment.