UP Squared does not allow me to install an OS on it

Mihai2402Mihai2402 Posts: 4New Member

I have recently received an Up Squared device. My purpose is to install Windows IoT Core on it, or Windows 10, either of them would be fine . Before going into more details let me just say that I have tried pretty much everything that I could find online(this forum, Google) and nothing works. What could I try more? I am in need of more ideas as I did not find my particular problem posted anywhere. Please help.

So now I am going to relate how I do things:
1. My setup
I have USB connected Mouse and Keyboard
I have a power supply cable connected to a Lenovo Laptop
I have an Internet Cable
Last but not least The USB Stick with Windows 10 installer on it(already tested on other devices to make sure it works, and it does)
2. I power up the UP Squared board and this is what happens next:



AS it can be seen, the board powers up no problem, it tries to boot when the spinning circles appear in the middle, and then everything shuts down.... And in starts all over again.... And it can do this forever (50 times at least counted by me)
3. I made sure that BIOS is working by going into it and seeing if the settings are correct, and as you may see from the pictures below, they are:


And this is pretty much it. I have tried to reset BIOS by unplugging then plugin the RTC battery, but with no luck at all. The only thing that I have not yet tried is to update BIOS, but as the tutorial mentioned it is a risky process so I am not sure I want to go into that. So please help, all help is greatly apreciated
Thank you!

Comments

  • ccaldeccalde Posts: 90New Member, Emutex mod

    Hi @Mihai2402 ,

    Your setup and BIOS configuration look fine...
    Did you try to clean your USB stick and flash your image using Etcher, for example?
    Also, you could repeat the process flashing some generic Ubuntu, to be sure the problem is not in the OS image.

    Cheers!

  • Mihai2402Mihai2402 Posts: 4New Member

    Hi @ccalde ,

    I used Rufus to clean and flash my image which I think is similar to Etcher. It also checks for bad blocks on the USB Sticks and I used the 4th level of check on them. I used 3 different USB sticks with the Windows 10 image downloaded from different sources, also tried WinPE and Windows IoT Core. Nothing works.. all of them have the exact same pattern. I starts up, it start to try and load from the USB stick(the part with the circling dots ), then it restars.
    I havent tried Ubuntu or something generic like that as I have no need for it. My project needs Windows, but I see your point in trying a different OS just to see how it behaves. Will give it a shot and will come back with updates. Meanwhile if there are any other suggestions I'm all ears.
    Cheers m8!

  • Mihai2402Mihai2402 Posts: 4New Member
    edited June 6

    Hi again @ccalde,

    Today I've tested that the every USB Stick with Windows 10 on it works, all 3 of them have the 64 bit version and I have:
    1 USB Stick Formatted and flashed as FAT32 GPT
    1 USB Stick Formatted and flashed as NTFS MBR
    1 USB Stick Formatted and slashed as FAT32 MBR
    I did manage chance a setting in BIOS and turned QUIET BOOT to OFF, and now I can clearly see it trying to boot, and then restarting over and over again until I power it off.

  • Mihai2402Mihai2402 Posts: 4New Member

    OK, so I finally got it. The issue was the power supply. Apparently It cannot draw the necessary power from a USB port. I managed to get a normal power supply of 5V with 5A and everything seems to work. It is installing Windows as I am writing.

Sign In or Register to comment.