Select Boot Device?

David New Member Posts: 30
Hi there!

i just installed my own Linux with a custom kernel - sadly this kernel has a bug and gets a kernel Panic during boot.

My Problem: i cannot boot from stick or DVD anymore because the Up-Board simply boots my custom efi-entry all the time, even if i disable it in the bios.

Is there a way to force the up to boot from a specified device?

Thanks in advance!


  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Hi David
    If you press F7 during boot (when the BIOS splash screen appears), do you see a choice of boot options?
  • David
    David New Member Posts: 30
    yes, i have. This is really weird:

    i only added one entry to uefi, but in bios i can see my named entry and "Android-IA". if i start with F7 i get the boot menu, but only Android-iA is visible, not my DVD, nor my usb-stick.

    if i disable the eMMC in bios, all devices ready for boot are listed when booting with F7. So my Workaround will be: disabling eMMC, Clearing the NVRAM from the UEFI and then try it again.

    Smells like a bug in the bios me thinks B)
  • David
    David New Member Posts: 30
    still no success. i bootet a live-dvd and cleared all efi-boot-entries.

    no luck, the board will still boot the corrupted kernel as soon as i re-enable the emmc.

    There is one bootmanager entry visible in the bios: "Android-TA". I cannot see, nor delete that via evivars and i cannot boot from an external media while the emmc is active. really weird. Someone has another suggestion?
  • Javier Arteaga
    Javier Arteaga Emutex Posts: 163 mod
    This might have something in common with another thread:
    Could you check if toggling the Boot > OS Image ID setting makes any difference?

    Thanks for the report!
  • David
    David New Member Posts: 30
    just as a side note: it works now. i switched between many usb-sticks and one did allow me to boot while the emmc is active. the one i used yesterday still only works while the emmc is deactivated - but yesterday i could leave the emmc activated no matter what.

    well, as long as it works now, i am fine ;)