UP Squared BIOS is gone

Hi all

I have updated the BIOS version to 3.3 but my board cannot turn on anymore. I read some post which mentioned that I can use the JTAG for FPGA 12pins to revive the die board by 1.8v voltage supplied. However, my sf100 cannot detect the chip.

If you have any experience pls share with me. Thanks a lot.

---Cz

Comments

  • AlingAling Administrator, AAEON, UP reseller Posts: 524 admin
    edited January 2018

    You will need to make a custom cable to connect with SF100.

    No need to support 5V for M/B .
    The voltage from SF-100 and make sure the voltage is 1.8V .
    Make a custom cable with below pin definition to connect with UP Squared CN22.

    Just add how to use SF100 in update the BIOS in wiki. https://wiki.up-community.org/BIOS_chip_flashing_on_UP_Squared

  • gezaxgezax New Member Posts: 1

    Hi,
    I messed things up the same way (V3.3 BIOS update), my UP SQUARED is bricked.
    This is what I tried to fix it:
    I installed flashrom (on a linux PC) and used a CH341A based programmer with a 1.8V level converter, desoldered the w25q128fw BIOS flash IC from the board, and soldered it to the programmer adapter. The downloaded BIOS .bin file was written to the flash IC (sudo ./flashrom -p ch341a_spi -w UPA1AM33.bin).
    Here is the output of flashrom:
    "Reading old flash chip contents... done.
    Erasing and writing flash chip... Erase/write done.
    Verifying flash... VERIFIED."
    Just to be sure I read back the content of the IC to a file and compared it to the original with totalcommander (they were the same).
    I resoldered the IC to the board and connected the 5V power. After that, only the blue LED lit up, no other activity was detected, it is still bricked. I have tried with V1.8 and V3.3 UP SQUARED BIOS versions with the same results. :/
    Can anyone tell me what I'm doing wrong?

    Thanks
    Geza

Sign In or Register to comment.