Up only boots into BIOS after BIOS update

AlexAlex Posts: 4New Member
UP: 32GB eMMC, 4GB RAM

I wanted to install ubilinux 4.0 so I updated the BIOS to the latest version as advised.
UPC1BM0X_EFI

Once updated ever time I boot the UP automatically enters BIOS setup.
If I press F7 I can see all my boot options but when I select one it just enters BIOS setup.

I tried loading default BIOS settings but it made no difference.

Comments

  • Nicola LunghiNicola Lunghi Posts: 131Emutex mod
    Dear duddled
    have you followed the instruction at https://up-community.org/wiki/Ubilinux ?
    Best Regards
    Nicola Lunghi
  • DCleriDCleri Posts: 508Administrator, Emutex admin
  • AlexAlex Posts: 4New Member
    I have tried the Ubilinux innstall image, Live Boot Ubuntu and bootable EFi shell. All enter the BIOS setup when selected.
    I have 6 UP boards and this only happens on the one I tried to update the BIOS of.
  • DCleriDCleri Posts: 508Administrator, Emutex admin
    Please disconnect the RTC battery for a couple of minutes, then reconnect the battery and boot up the system.

    Does the UP BIOS logo show up after boot? If so please press F7 and let me know what are the available options.
  • AlexAlex Posts: 4New Member
    When I press F7 without a bootable USB the options are
    [ul]
    [li]Enter Setup[/li]
    [/ul]

    If I press F7 with my Ubuntu USB is shows
    [ul]
    [li]UEFI: Corsair Voyger Sl.....[/li]
    [li]Enter Setup[/li]
    [/ul]

    But irrespective of which option I select it entered the Aptio Setup Utility.
  • KevinKevin Posts: 8New Member
    I have encountered this issue with my upboard^2 and bios UPA1AM18.
  • AlexAlex Posts: 4New Member
    I am going to RMA mine.
  • ashwinvijayakumarashwinvijayakumar Posts: 1New Member

    Same problem, but I am seeing this issue out of box. The board never booted to an OS. I was able to boot from an Ubuntu 16.04 USB stick and install the OS, but the board never boots into the OS. It keeps booting into BIOS setup.

    BIOS Version: UP-APL01 R2.1 (9/1/2017)

  • Jesse KaukonenJesse Kaukonen Posts: 39New Member ✭✭
    edited July 27

    Does the eMMC get detected at all in the BIOS? We had a couple of Ups that suddenly had the eMMC disappear completely. If the board keeps booting to BIOS it could mean there's nothing bootable discovered, which hints at some problem with the eMMC.

  • DCleriDCleri Posts: 508Administrator, Emutex admin

    Please make sure you are installing the system with boot/grub in UEFI mode and not legacy.

    During installation you can select manually to partition your disk, then delete all partitions and create new ones (1 EFI partition 512MB, a root partition with the remaining space).

Sign In or Register to comment.