no ACPI WakeUp

test.ittest.it Posts: 6New Member
edited September 2017 in Others
Has anybody try out ACPI WakeUp with the Up Squared?
I don't manage to get the ACPI WakeUp working under easyVDR 3.0 (Linux easyVDR 4.4.0-93-generic #116~14.04.1-Ubuntu SMP) ...
Tagged:

Comments

  • rogertsai(AAEON)rogertsai(AAEON) Posts: 97New Member ✭✭
    Hi test

    This function need the kernel 4.6 or above to support that
  • test.ittest.it Posts: 6New Member

    So i try it with ubilinux
    root@ubilinux4:/# uname -r 4.9.45-ubilinux+
    and a simple wakeup test
    Wake Up Linux With an RTC Alarm Clock

    root@ubilinux4:/# sudo sh -c "echo 0 > /sys/class/rtc/rtc0/wakealarm"
    root@ubilinux4:/# sudo sh -c "echo `date '+%s' -d '+ 3 minutes'` > /sys/class/rtc/rtc0/wakealarm"
    root@ubilinux4:/# cat /proc/driver/rtc

    rtc_time : 21:09:04
    rtc_date : 2017-12-21
    alrm_time : 21:11:30
    alrm_date : 2017-12-21
    alarm_IRQ : yes
    alrm_pending : no
    update IRQ enabled : no
    periodic IRQ enabled : no
    periodic IRQ frequency : 1024
    max user IRQ frequency : 64
    24hr : yes
    periodic_IRQ : no
    update_IRQ : no
    HPET_emulated : yes
    BCD : yes
    DST_enable : no
    periodic_freq : 1024
    batt_status : okay

    root@ubilinux4:/# shutdown -P now

    The board dont comes back up in ~3 minutes!!!

  • test.ittest.it Posts: 6New Member
    edited December 2017

    The same with "hpet=disable" as kernel Parameter, no ACPI WakeUp. :(

  • test.ittest.it Posts: 6New Member

    Forgives my bad english!
    Yet another try under 4.9.45-ubilinux+.
    NO ACPi WAKEUP!
    Please, can somebody try the following in a root terminal?
    sudo rtcwake -m no -s 60 && sudo poweroff
    The system should "poweroff" and wakeup after roughly 60 seconds, theoretical...

    ACPI Wake is essential for me because I want to use the UP Squared as a VDR (VideoDiskRecorder [easyVDR])!

    Thanks a lot!!

  • rogertsai(AAEON)rogertsai(AAEON) Posts: 97New Member ✭✭

    Did you enable RTC wake function in your BIOS? If not, please try it and set to dynamic Time mode, and set 1 for wake up minute incr as bleow

    Bios path for boot option: Advanced --> Power Management

  • test.ittest.it Posts: 6New Member

    If I set "RTC wake system from [Dynamic Time]" to 1 the system powered up after 1 minute.
    "RTC wake system from [Static Time]" works also.
    But the problem is to set the wake up time by linux's ACPI Wakeup.
    Under Ubilinux RTC wake BIOS funktion is disabled.

Sign In or Register to comment.