Hello!

DominicDominic New Member Posts: 3
Hi everybody, purchased an UP 2/16 last week.
Installed ubuntu 16.04 with up kernel, testing my apps.
So far very pleased with Up's performance and build quality, but struggling with i/o.

Comments

  • DCleriDCleri Administrator, AAEON Posts: 1,002 admin
    Hi Domius,

    We will release an updated ubilinux (based on Debian Stretch) next week which includes the I/O support.

    Later in June also you will be able to download a custom Kernel for Ubuntu which will enable the I/O on UP Squared.
  • DominicDominic New Member Posts: 3
    edited June 2017
    Hi Dcleri!
    Thank you for prompt reply. Sorry for my ambiguity, my UP is not squared, but 2GB ram / 16GB mmc version.
    My problem are floating inputs. This next message from system log is generated when my app sets pull-up / down mode: "gpio27: mode: Failed to open 'drive' for writing: No such file or directory"
    Tried with pull-up resistors, no success. Problem gets worse once the UART port is activated.
    App is written in Java, using mraa library.
    Are internal pull-up/down resistors going to be supported in new release?


    BR
  • Dan O'DonovanDan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Hi domius
    Unfortunately the hardware on UP does not provide configurable pull-up/down resistors for the 40-pin header. So you would need to use external pull-up resistors instead.
    -Dan
  • DominicDominic New Member Posts: 3
    Hi Dan
    What is recommended resistor value for the pullup?
    Tried many:1.8, 2.2, 4.7, 10k, no success, still floating.
  • Dan O'DonovanDan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    I'd say it would depend on the rest of the circuit that you have connected. But those resistor values should generally be fine.
    Before I could help you further, I think I would need more insight on which pins you're using, how exactly you are setting up and using those pins, and how the issue is manifesting.
Sign In or Register to comment.