I installed ubuntu-16.04.2-desktop-amd64.iso Still no serial port working.

Raymond DayRaymond Day New Member Posts: 67
I downloaded ubuntu-16.04.2-desktop-amd64.iso right from this UP web place and installed it.

Wanted to get the serial port working and did just what it says to do on the /etc/default/grub.d file.

When I got to update-grub it comes back with:
[email protected]:~# update-grub
"nvalid output terminal "gfxterm serial

Any way to fix this?

On my old install of ubuntu server I got the serial to work at lest to send data but I could not type on it.

-Raymond Day

Comments

  • Raymond DayRaymond Day New Member Posts: 67
    [/url]Looked on Google for help with this.

    It worked so when I do the update-grub I get no error.

    So I rebooted and all the serial port shows now is this:
    error: serial port `com0' isn't found.
    error: terminal `serial' isn't found.
    error: terminal `serial' isn't found.
    error: no video mode activated.
    

    I guess it's not com0 but I thought it would be How they talked about it here..

    Checked what com ports it uses by doing a apt install setserial then this:
    [code][email protected]:~# setserial -g /dev/ttyS[0123456789]
    /dev/ttyS0, UART: unknown, Port: 0x03f8, IRQ: 4
    /dev/ttyS1, UART: unknown, Port: 0x02f8, IRQ: 3
    /dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
    /dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
    /dev/ttyS4, UART: 16550A, Port: 0x0000, IRQ: 4
    /dev/ttyS5, UART: 16550A, Port: 0x0000, IRQ: 5
    /dev/ttyS6, UART: unknown, Port: 0x0000, IRQ: 0
    /dev/ttyS7, UART: unknown, Port: 0x0000, IRQ: 0
    /dev/ttyS8, UART: unknown, Port: 0x0000, IRQ: 0
    /dev/ttyS9, UART: unknown, Port: 0x0000, IRQ: 0
    [email protected]:~#
    
    [/code]

    Edit the /etc/default/grub.d/serial.cfg file to put com 4 in it not 0.

    Did update-grub again and rebooted.

    Now says:

    error: serial port `com4' isn't found.
    error: terminal `serial' isn't found.
    error: terminal `serial' isn't found.
    error: no video mode activated.


    So maybe it's 5 but at lest I got some other text back on the serial port this time.
    [   29.215540] mmc1: Timeout waiting for hardware interrupt.
    [   29.221581] sdhci: =========== REGISTER DUMP (mmc1)===========
    [   29.228097] sdhci: Sys addr: 0x00000020 | Version:  0x00001002
    [   29.234611] sdhci: Blk size: 0x00007200 | Blk cnt:  0x00000020
    [   29.241117] sdhci: Argument: 0x06140870 | Trn mode: 0x0000003b
    [   29.247633] sdhci: Present:  0x1fff0001 | Host ctl: 0x0000003d
    [   29.254138] sdhci: Power:    0x0000000b | Blk gap:  0x00000080
    [   29.260653] sdhci: Wake-up:  0x00000000 | Clock:    0x00000007
    [   29.267169] sdhci: Timeout:  0x00000004 | Int stat: 0x00000000
    [   29.273676] sdhci: Int enab: 0x02ff000b | Sig enab: 0x02ff000b
    [   29.280193] sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
    [   29.286710] sdhci: Caps:     0x546ec881 | Caps_1:   0x80000807
    [   29.293227] sdhci: Cmd:      0x0000123a | Max curr: 0x00000000
    [   29.299733] sdhci: Host ctl2: 0x0000008d
    [   29.304113] sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0x000000026db07200
    [   29.311403] sdhci: ===========================================
    [   29.322195] mmcblk1: error -110 transferring data, sector 101976176, nr 32, cmd response 0x0, card status 0x0
    

    But I still can not type on it.

    -Raymond Day
  • Raymond DayRaymond Day New Member Posts: 67
    That last part on the last post of "mmc1: Timeout waiting for hardware interrupt." keeps repeating seems like all most every time I do a command on the system.

    I did not get that when I had just the server installed. Now have the Desktop installed of Ubuntu.

    -Raymond Day
  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    Hi
    in Ubuntu the serial number could be different than tty0.

    Do this:
    [ol]
    [li]execute
    sudo find /sys/devices/pci0000\:00 -name *tty*
    /sys/devices/pci0000:00/0000:00:18.0/dw-apb-uart.8/tty
    /sys/devices/pci0000:00/0000:00:18.0/dw-apb-uart.8/tty/ttyS4
    /sys/devices/pci0000:00/0000:00:18.1/dw-apb-uart.9/tty
    /sys/devices/pci0000:00/0000:00:18.1/dw-apb-uart.9/tty/ttyS5
    
    and take note of the number of the terminal where the first uart is (in my case ttyS4)
    [/li]
    [li]modify as the guide says the grub configuration like this
    sudoedit /etc/default/grub.d/serial.cfg
    

    GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX console=tty0 console=ttyS4,115200n8"
    GRUB_TERMINAL="console serial"
    GRUB_SERIAL_COMMAND="serial --unit=0 --speed=115200"
    [/li]
    [li]
    sudo update-grub
    
    [/li]
    [li]start the serial terminal with:
    sudo systemctl start [email protected]
    
    [/li]
    [li]enable permanently the serial terminal with:
    sudo systemctl enable [email protected]
    
    [/li]
    [/ol]
  • Raymond DayRaymond Day New Member Posts: 67
    Thanks I did what you said and the 1st time seems like the commands worked and I rebooted. But no serial port still.

    So log on again and copied and paste your /etc/default/grub.d/serial.cfg I think I had it the same any way but wanted to make sure.

    But then I got a Not foundrub-mkconfig like this:
    login as: root
    [email protected]'s password:
    Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 4.10.0-33-generic x86_64)
    
     * Documentation:  https://help.ubuntu.com
     * Management:     https://landscape.canonical.com
     * Support:        https://ubuntu.com/advantage
    
    0 packages can be updated.
    0 updates are security updates.
    
    Last login: Thu Sep 14 06:25:30 2017 from 192.168.86.59
    [email protected]:~# find /sys/devices/pci0000\:00 -name *tty*
    /sys/devices/pci0000:00/0000:00:18.0/dw-apb-uart.8/tty
    /sys/devices/pci0000:00/0000:00:18.0/dw-apb-uart.8/tty/ttyS4
    /sys/devices/pci0000:00/0000:00:18.1/dw-apb-uart.9/tty
    /sys/devices/pci0000:00/0000:00:18.1/dw-apb-uart.9/tty/ttyS5
    [email protected]:~# nano /etc/default/grub.d/serial.cfg
    [email protected]:~# update-grub
    : not foundrub-mkconfig: 4: /etc/default/grub.d/serial.cfg:
    [email protected]:~#
    
  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    edited September 2017
    double check all the parenthesis on the file /etc/default/grub.d/serial.cfg sometimes the wiki changes the parenthesis type

    if it doesn't work delete the file /etc/default/grub.d/serial.cfg and modify directly the /etc/default/grub file

    1. change the line
    GRUB_CMDLINE_LINUX=""
    
    with
    GRUB_CMDLINE_LINUX="console=tty0 console=ttyS4,115200n8"
    
    2. change the line
    #GRUB_TERMINAL=console
    
    with
    GRUB_TERMINAL="console serial"
    
    3. add after that line
    GRUB_SERIAL_COMMAND="serial --unit=0 --speed=115200"
    
    4. sudo update-grub

    it works for me I've just tried it
    Also double check if your serial cable is working

    In theory after giving the command:
    sudo systemctl start [email protected]
    
    you should have a shell after boot in any case

    (the grub lines are only to control grub and to see the kernel init message during boot)

    If you cannot see a terminal then maybe you have a problem in your serial connection.
  • Raymond DayRaymond Day New Member Posts: 67
    That worked. I did delete it and made a new one.

    Then rebooted but still don't get any thing over the serial port. I think I did see it before but just could not send any thing. Now can't even see it.

    The end of a "dmesg" is about all in red. It looks like this:
    [   38.628764] mmc0: Timeout waiting for hardware interrupt.
    [   38.634805] sdhci: =========== REGISTER DUMP (mmc0)===========
    [   38.641319] sdhci: Sys addr: 0x00000008 | Version:  0x00001002
    [   38.647833] sdhci: Blk size: 0x00007200 | Blk cnt:  0x00000008
    [   38.654347] sdhci: Argument: 0x05d109a8 | Trn mode: 0x0000003b
    [   38.660861] sdhci: Present:  0x1fff0001 | Host ctl: 0x0000003d
    [   38.667375] sdhci: Power:    0x0000000b | Blk gap:  0x00000080
    [   38.673884] sdhci: Wake-up:  0x00000000 | Clock:    0x00000007
    [   38.680400] sdhci: Timeout:  0x00000004 | Int stat: 0x00000000
    [   38.686914] sdhci: Int enab: 0x02ff000b | Sig enab: 0x02ff000b
    [   38.693427] sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
    [   38.699941] sdhci: Caps:     0x546ec881 | Caps_1:   0x80000807
    [   38.706452] sdhci: Cmd:      0x0000123a | Max curr: 0x00000000
    [   38.712963] sdhci: Host ctl2: 0x0000008d
    [   38.717341] sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0x000000026db69200
    [   38.724630] sdhci: ===========================================
    [   38.735394] mmcblk0: error -110 sending stop command, original cmd response 0x0, card status 0x400900
    [   38.735397] mmcblk0: error -110 transferring data, sector 97585576, nr 8, cmd response 0x0, card status 0x0
    [email protected]:~#
    

    Not sure if that has any thing to do with the serial.

    Thanks for helping.

    -Raymond Day
  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    That error message has nothing to do with the serial

    the uart is ttyS4

    please check to do not have any other file in /etc/default/grub.d
    if you have it please remove it and run update-grub again

    as I was saying if you cannot see a serial terminal after boot and the service is enabled you probably have problem with you adapter/cable/etcetc
    please check that your adapter is 3.3v and the wiring
  • Raymond DayRaymond Day New Member Posts: 67
    It worked. I switched the send and receive wires. Can't remember if I switch them before.

    Here is what comes back it looks like no kernel booting code or just very little.
    Version 2.18.1263. Copyright (C) 2017 American Megatrends, Inc.
    Press <DEL> or <ESC> to enter setup.
    
    error: serial port `com0' isn't found.
    error: terminal `serial' isn't found.
    error: terminal `serial' isn't found.
    error: no video mode activated.
    error: no suitable video mode found.
    Booting in blind mode
    
    Ubuntu 16.04.3 LTS Ubunt-UP-APL01 ttyS4
    
    Ubunt-UP-APL01 login: root
    Password:
    Last login: Thu Sep 14 07:19:02 EDT 2017 from 192.168.86.59 on pts/8
    Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 4.10.0-33-generic x86_64)
    
     * Documentation:  https://help.ubuntu.com
     * Management:     https://landscape.canonical.com
     * Support:        https://ubuntu.com/advantage
    
    0 packages can be updated.
    0 updates are security updates.
    
    [   39.865830] mmc0: Timeout waiting for hardware interrupt.
    [   39.871865] sdhci: =========== REGISTER DUMP (mmc0)===========
    [   39.878373] sdhci: Sys addr: 0x00000010 | Version:  0x00001002
    [   39.884885] sdhci: Blk size: 0x00007200 | Blk cnt:  0x00000010
    [   39.891389] sdhci: Argument: 0x0659df20 | Trn mode: 0x0000003b
    [   39.897902] sdhci: Present:  0x1fff0206 | Host ctl: 0x0000003d
    [   39.904436] sdhci: Power:    0x0000000b | Blk gap:  0x00000080
    [   39.910948] sdhci: Wake-up:  0x00000000 | Clock:    0x00000007
    [   39.917451] sdhci: Timeout:  0x00000004 | Int stat: 0x00000000
    [   39.923964] sdhci: Int enab: 0x02ff000b | Sig enab: 0x02ff000b
    [   39.930466] sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
    [   39.936978] sdhci: Caps:     0x546ec881 | Caps_1:   0x80000807
    [   39.943492] sdhci: Cmd:      0x0000123a | Max curr: 0x00000000
    [   39.950006] sdhci: Host ctl2: 0x0000008d
    [   39.954383] sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0x000000026d9c7200
    [   39.961672] sdhci: ===========================================
    [   39.972344] mmcblk0: response CRC error sending r/w cmd command, card status 0x400900
    [email protected]:~#
    

    Wow after all this time got it working.

    Thank you.

    -Raymond Day
  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    edited September 2017
    Hi
    glad it worked (usually is the simplest thing that goes bad)

    you still have some configuration problem (and the emmc error doesn't look good)

    I suggest you to do a clean ubuntu install and then reenable the serial terminal

    Also why don't you try our new ubilinx4?
  • Raymond DayRaymond Day New Member Posts: 67
    What is ubilinx4 ? I guess I have to reload it to get rid of the errors. Were is a link to the best ISO to reload it?

    -Raymond Day
  • roddinesroddines New Member Posts: 9
    edited December 2019

    error: serial port 'com0' isn't found.
    error: terminal 'serial' isn't found.
    error: terminal 'serial' isn't found.
    error: no video mode activated.

    These errors are usually caused by the presence of GRUB_HIDDEN_TIMEOUT=0 in /etc/default/grub
    Even though the default value is =0 this seems to cause the errors.

    The solution is to:
    Edit: sudo nano /etc/default/grub
    Deactivate the following line by commenting it out or deleting it:
    #GRUB_HIDDEN_TIMEOUT=0

    Refer: https://askubuntu.com/questions/475993/grub-update-warning-in-ubuntu-14-04
    Refer: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/699802

Sign In or Register to comment.