Newest W10 64-bit UP Board graphics drivers are bunk!

JohnJohn New Member Posts: 1
After installing a fresh copy of Windows 10 Professional onto my UP Board, I have found that the UP Board drivers for 64-bit W10 posted as of 11/5/17 do not contain the correct graphics drivers. The drivers provided are for Atom Z3700 Series instead of Z8350. The installation unsurprisingly fails. Such a severe oversight it quite disappointing, especially considering that these are drivers provided by the board manufacturer...

Get it together, UP!


  • rogertsai(AAEON)rogertsai(AAEON) New Member Posts: 268 ✭✭✭
    edited November 2017
    Can you provide your driver installation fails picture for me?
    This message about the Atom processor Z3700 series drivers is by intel provided, so it's should be compatible with Z8350
    BTW, It works for me, OS:Windows 10 1607
  • Edward ThomasEdward Thomas New Member Posts: 20
    Having installed Windows 10 Pro on my UP Squared, the only screen resolution I could get was 800x600. No other options were available. None of the UP driver updates solved the problem so I went and got the graphics driver from Intel for this chip. Installed the driver and now the computer goes through an endless cycle of trying to start up, showing the BIOS splash screen at a higher resolution and then restarting. Really not good. I am now completely reinstalling Windows but I am not very happy about an issue that should not be a problem.
  • rogertsai(AAEON)rogertsai(AAEON) New Member Posts: 268 ✭✭✭
    edited November 2017
    Oh, that's a fundamental misunderstanding to the UP
    I thought you said "UP board" not "UP Squared", Please click on the link below to download the drivers for your UP Squared, and try again

    i think you install wrong driver for your UP Squared board....
  • Edward ThomasEdward Thomas New Member Posts: 20
    Unfortunately, I have already tried to install the driver for the UP Squared. Every time I try to install a new graphics driver (from UP or Intel) the UP2 crashes and restarts and leaves me stuck with the basic Microsoft driver.
  • Edward ThomasEdward Thomas New Member Posts: 20
    When I go in through the Windows safe mode and install the Intel HD driver completely manually, the UP2 goes into a continuous cycle of crashing and restarting until I have to completely restore Windows.

    Any possibility this is some kind of BIOS problem?
  • Edward ThomasEdward Thomas New Member Posts: 20
    I guess this one is going back to the dealer. We'll see how the next one does.
  • Edward ThomasEdward Thomas New Member Posts: 20
    I would say that the problem has something to do with the graphics driver. I am on my second board now and neither of them will operate with anything other than the Microsoft Basic Graphics Driver. 800x600 resolution is pretty much useless. Just like the other posters, if I try to change the graphics driver to an Intel driver (be it the one provided by UP or one from Intel directly), the machine goes into an endless series of boots and crashes (just before you get into Windows) until the repair screen finally comes up and you have to go into Safe Mode and remove the Intel driver. This is running Windows 10 Pro, which the machine is supposed to be able to handle. I have tried updating the BIOS as well with no change. I have jumped through every hoop that UP/Aaeon has put out without success and am only told that the problem doesn't occur with their board.

    I also tried to install SSD and wireless boards and they appeared to not work either. I had high hopes for using this product for my business but it appears to be junk at this point. Better off keeping with the far more expensive NUC I guess. UP is unable to come up with a reason for the problem or a solution. I'm in the US so I have to purchase from Mouser unless I want to pay some ridiculous $60+ tax (which I assume is some kind of estimated import tax which they have no right to charge) to order it directly from UP. Unfortunately, Mouser is somewhat difficult to deal with when it comes to returns and UP/Aaeon will not deal with RMA/warranty issues for their products purchased through their dealer (a poor way of doing business). Overall, it has been a very disappointing experience, and while I have a standard UP Board on the way, I may very well not bother with it (because it would likely have the same issue) unless someone has come up with a solution to this problem.
  • NoelStephensNoelStephens New Member Posts: 25
    For what it is worth:

    I am running the most recent version of Windows 10 x64 on an UpBoard using the drivers provided here:
    As well, I had flashed my UpBoard's bios with the 64-bit version located here:

    Attached to this reply is a screen grab of the UpBoard's Device Manager, System Information, and the Intel Graphics Driver application running as well as properly functioning.

    Either case, I can confirm that with the "latest greatest" of the BIOS and Drivers, that Windows 10 x64 runs just fine.

    I can't vouch for Windows IoT or Windows x86 at this time, but at a minimum I figured it might put you at ease that (unless the standard upboard on the way to you is defective) it should "work as expected". The *only* caveat is that if you plan on using I2C on the board you will most likely have to wait 2-3 months while the drivers and BIOS update to allow for that are finalized.
    (more on the I2C stuff here:

  • NoelStephensNoelStephens New Member Posts: 25
    Realized the image I sent was too large and would be hard to see, I am attaching that same image broken into two parts so you can actually read the text in the screenshot to confirm it is indeed working.

  • Edward ThomasEdward Thomas New Member Posts: 20
    I have installed the most recent BIOS and am using Windows 10 Pro. I just tried a suggestion that I got in another thread and the problem is still not solved. Aaeon has guaranteed that they can supply me with a working board in the US so I guess that I just have to figure out how to return another board to Mouser.
  • Edward ThomasEdward Thomas New Member Posts: 20
    The graphics drivers for the standard UP Board appear to work just fine. So I got the UP Board in today and installed Windows 10 Pro. Even during installation I could tell something was different from the UP2 board since everything was in high resolution. After installation the screen resolution was set at 1920x1080 (no other choices). Now the interesting thing is that the graphics driver is the Microsoft Basic Display Adapter just like with the UP2 but at least this time it is allowing for a reasonable resolution. I did a driver update through the device manager and the Intel HD driver was automatically installed. Now the screen works in high resolution with various resolutions available to select. Completely different experience from the UP2.
  • NoelStephensNoelStephens New Member Posts: 25
    Just as a reminder, Intel had just recently posted the first public revision of the Cherry Trail (Intel Atom Z83XX) bsp. I believe most manufacturers utilizing this specific processor line have been working with a pre revision 1.0 bsp images, and as such most drivers posted for this particular processor did not support full hardware acceleration.

    Anyway, the standard UpBoard's *only* shorting coming (IMO) was their GPIO and I2C architectural delivery choice (FPGA) to deliver IoT related IO to the appropriate pin on the 40 pin connector. Hopefully there can be a faster delivery of the next BIOS update and SDK images to allow for both GPIO and I2C under Windows 10 (excluding IoT Core as that requires a different type of integration).

    So if your project can do without I2C (at least for the next couple of months), then most everything else works good enough to get the majority of your framework in place. If not, then it will be the next item in your list of things you need working.

    Glad your new UpBoard works as expected (hearing that it is consistently working up to I2C and some other odd-ball interfaces is a good thing).

  • Paul1966Paul1966 New Member Posts: 1
    edited January 2019

    Hi, I had also a problem with the video driver, the up board froze when the video driver was loaded. In the end I found out that the power supply I used was not ok, not stabilized enough or something like that.
    After using another power supply the drivers could be loaded without a freeze .

Sign In or Register to comment.