Tensorflow import problem

HariomHariom New Member Posts: 2

Hi,

This is Hariom Singh. I am using UP board with 4 GB RAM and 64 GB memory with Ubuntu 18.04. I have installed tensorflow 1.14.0. When I am importing tensorflow ( import tensorflow ) that time I am getting error " illegal instruction ( core dumped )". I tried this with tensorflow version 1.13, 1.6, 1.8 and 2.0. I am getting same error.

For tensorflow 1.5 I am able to import tensorflow but when I am running my program (object detection )that time it is showing error "No op named NonMaxSuppressionV3" in defined operations.

So please help me how can I resolve these errors.

Thanks

Comments

  • DCleriDCleri Administrator, AAEON Posts: 922 admin

    As you are installing manually, your are encountering a well known issue. Tensorflow 1.5 requires AVX CPU extensions but those CPU extensions are only available on Core-i CPUs, so it won't work on UP Board or UP Squared.

    You would need to downgrade tensorflow to version 1.4 or use OpenVINO which will manage or the dependencies and modules versions.

  • HariomHariom New Member Posts: 2

    I am getting same error with tensorflow version 1.4 also.
    Can you tell me UP Xtream will be suitable for tensorflow or not.

  • DCleriDCleri Administrator, AAEON Posts: 922 admin
    edited February 13

    Hi @Hariom

    You cannot get the same error as NonMaxSuppressionV3 is only available on TF1.8 or newer.
    if you are running a model trained on TF 1.5 or above on TF1.4 it won't work either, you need a model trained with TF1.4.

    All our platforms can run tensorflow with different settings.
    So if you want to make sure that latest versions is working on your specific platform, the suggestion is to compile it from source.
    Please follow this page for more information: https://docs.openvinotoolkit.org/latest/_docs_MO_DG_Known_Issues_Limitations.html

    UP Xtreme Core-i3 i5 or i7 have AVX instructions and can run any pre-compiled Tensorflow binary

Sign In or Register to comment.