No output to screen

Mischa Gorinskat
Mischa Gorinskat New Member Posts: 1

Haven't been playing with my up-board till a few weeks ago, since i didn't have a proper power adapter. I purchased one according to the specs of the UP board and wanted to install the latest UbiLinux on it. However i don't get any output on any of my screens.

I've connected a usb keyboard, usb stick with UbiLinux and via HDMI the Up board is connected to my TV. The TV is set to the correct input channel. Then i plugged in the power, the blue power LED turns on, but i don't see anything on my screen. It just keeps black.
I've removed all USB connected devices and power it on again, no result. Additionally i've tried connecting it to my Monitor, via a HDMI DVI adapter, also no success. Double checking the adapter works with my laptop and an hdmi cable.
Then i connected my RPI via the cables, to make it wasn't related to that, that worked great.

What other options do i have to check what's wrong?



  • DCleri
    DCleri Administrator, AAEON Posts: 1,213 admin
    Hi m038,

    First of all you can try to reset your BIOS, removing the RTC battery for few seconds and then re-plugging it. Then try to power up the board. Does it work?

    if not, can I ask where you got your HDMI cable from?
    You can try a different HDMI cable as we have noticed other people having a similar issue sometimes.
  • ilan
    ilan New Member Posts: 16
    you need to test with PC monitor.
    Hopefully you did nothing drastic yet, maybe even solved.
  • Mike Foley
    Mike Foley New Member Posts: 4
    I have the same issue. This is a new UP board which I received on Friday. I'm using a 5V 4A power supply. I tried to unplug the battery, hit reset, etc. I've also tried toggling the monitor power, etc. I'm using a PC monitor connected via HDMI (I've tried two different cables). A Raspberry Pi outputs to this display with the same cable without issue. Nothing ever appears on the display. It is always black.

    I'm going through the forums to see if there is anything else, but this board seems bad.
  • ilan
    ilan New Member Posts: 16

    First I recommend you watch MickMake's EXCELLENT clip (regarding heating on LattePanda) .
    Is the connector physically intact ?
    Is the PS supplying the Power it claims it does ?
    Usually monitors have a discover plugged source function - you could try it.
    Is there a difference between the RPi and UP regarding HDMI specs ?
    Could the OS be put to blame ?
    What about a Live CD linux ?
    Does the UP's BIOS have any related settings ?

    Order the suggestions from easy to messy and start testing :)

    Cheers & GL
Privacy Policy