[SOLVED] Unable to install Ubuntu

Al BeeAl Bee New Member Posts: 6
edited October 2016 in UP Board Linux
We're following the Wiki instructions to install Ubuntu-16.04.1 and able to reach the boot menu and select "Install Ubuntu". However, a few seconds later we get these messages:

efi: requested map not found.
esrt: ESRT header is not in the memory map.
i8042: Can't read CTR while initializing i8042


And a little bit after the above messages appear, we get a blank green screen and the installation never completes. We tried with multiple different brand new USB sticks and used rufus to make them uefi bootable. We also tried with Ubuntu-14.04.4, but we got the same failure result.

Comments

  • Chris BothaChris Botha New Member Posts: 48
    I installed it successfully using multi boot along side win10, I used rufus to make the uefi bootable USB stick. Not sure it helps at all.

    Interestingly enough I was unable to install the ubilinux from the files here, it fails on detect network, from a working network cable in the board, then of course everything network related fails after that. I was keen to try out the rpi.gpio install as I seem to be going nowhere fast with the windows api. ..
  • Al BeeAl Bee New Member Posts: 6
    I also used rufus to make them uefi bootable Ubuntu-14.04.4 and Ubuntu-16.04.1, but we get the same failure result.
  • Chris BothaChris Botha New Member Posts: 48
    as per another thread, start the setup without any network cable installed, let it fail (it will) then staying on the failure notice screen, plug a wifi dongle in, wait till it stops flashing then exit the error screen, remove the dongle and plug your network in. restart detection, second time around it works.
  • Al BeeAl Bee New Member Posts: 6
    edited October 2016
    Edit the command for the "Install Ubuntu" option in the GRUB menu option and add the 'nomodeset' parameter to the linux line 'quiet splash nomodeset ---'. Then, press Ctrl-x or FN F10 to boot. This will allow you to reach the Installation Options.

    Notice that the above it's just a temporary workaround to allow you to complete the Ubuntu installation. Once Ubuntu is installed, then you need to set the 'nomodeset' permanently by adding this option to the /etc/default/grub file. Otherwise, you will get the blank screen again.

    Immediately after the UP splash screen appears during boot, press and hold the ESC key. In the Password dialog, don't type anything; just press Enter. Then press ESC again, select Yes, and quickly press and release the ESC key. That will bring you the GRUB menu. Select the 'Advanced options for Ubuntu' and select the (recovery mode) option. Then just resume the boot up; which will allow you to reach the Ubuntu desktop. Open the Terminal and do the following:

    sudo nano /etc/default/grub

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

    then save it

    sudo update-grub

    Reboot

    After rebooting, execute these final steps.


    I hope this helps others trying to install Ubuntu on the UP-board. Please post here if you know a different workaround.
  • RiccardoRiccardo New Member Posts: 5
    Hi cagiva....

    Look at my post here where I am facing the same problems but I was not able to solve them.
  • RiccardoRiccardo New Member Posts: 5
    @cagiva

    I purchased an UpBoard 2/32 with the recommended 10.1" screen connected via MIPI-DSI.
    To make it run you have to enable it from the BIOS under the "Northern Bridge" menu.

    Then I tested the UpBoard using a HDMI cable on a standard PC Monitor and...

    BE AWARE IF YOU CONNECT YOUR UpBoard USING THE HDMI CABLE TO AN EXTERNAL SCREEN MAKE SURE YOU DISABLE THE MIPI-DSI OUTPUT!

    The side effect if that Ubilinux and Ubuntu will become unstable close to unusable!

    Manufacturers should take this tip into account to notify the user or either fix the issue.
  • SimonSimon New Member Posts: 1
    I have the instability problem with ubuntu 14.4
    The version 16 seems to be more stable. The MIPI-DSI is disabled but I cannot install the distribution. When I get to the last menu entry and I click INSTALL, the hdmi sends crap and I can't see nothing anymore.
Sign In or Register to comment.