Up board without RTC battery doesn't boot from emmc

Options
Hi there,
I have recently received 2 Up boards (2G/16G) and I correctly installed Ubuntu with patch following the wiki on the emmc and it worked like a charm.
I rebooted the system and it worked very well.

But...
in my application i need to remove the RTC battery beacuse I don't need RTC and when the battery will be exausted my former customers will never replace it.

So I pulled out the battery out and surprise!!! The default BIOS doesn't recognize emmc (in start F7 menu no units appears). The only way to boot the machine is reinstall the OS using USB key.

Anyone know how to set default bios (without RTC battery) to recognize emmc? Is that bug corrected in latest BIOS images?

I think that an embedded board RTC battery dependant in my application is unusable.

Please help me.

Thank You in advance.

Comments

  • Pierre
    Pierre New Member Posts: 3
    edited October 2016
    Options
    Same here using plain Debian

    I was able to boot again by manually selecting filesystem (by typing 'fs0:') and running '/EFI/debian/grubx64.efi'
    To fix it, once booted I ran 'grub-install /dev/mmcblk0' as root

    I too would like to be able to operate the board even when RTC battery is depleted.
    Is there some kind of default boot entry that would not be deleted when the battery is unplugged ?

    I saw on several machines that grub installed itself of '/EFI/boot/bootx64.efi' ; may it be the default UEFI boot entry ?
  • Pierre
    Pierre New Member Posts: 3
    edited October 2016
    Options
    OK, that was quite fast...

    I indeed can successfully reboot the board without its RTC battery connected after I copied '/boot/efi/EFI/debian/grubx64.efi' to 'boot/efi/EFI/boot/bootx64.efi' (I didn't managed to create a symbolic link or tell grub to install itself there)
  • Michele
    Michele New Member Posts: 6
    Options
    Yep!!
    Fantastic, it works!

    Thank You Pierre, You solved a big problem in a very easy way.


    P.S.: Hei Emutex guys, why not include this fix in next Ubilinux release?
Privacy Policy