Has anyone got a working UEFI x64 PXE boot?

J M EJ M E New Member Posts: 11
Despite trying many variations the board refuses to initiate a TFTP request for the next stage boot binary (in this case x64 syslinux.efi). The board is flashed with the latest x64 firmware.

If anyone has got a working PXE boot setup with their UP board I really like to hear from them. What would be phenomenally useful is a Wireshark trace of the process.

Many thanks.

Jerry

Comments

  • J M EJ M E New Member Posts: 11
    For anyone else attempting this the (partial) solution is to use the Syslinux 6.04-pre x64 EFI loader. The mainline 6.03 is bug ridden apparently and simply fails. Although the transfer time is incredibly slow (~4 minutes for a kernel and InitRAM FS) it does boot.
  • Chad ParryChad Parry New Member Posts: 2
    I've tried and failed to get PXE boot to work. I've flashed the UPC1BM0X_EFI BIOS. I'm using the version "syslinux-6.04-pre1", as suggested. The syslinux menu loaded just fine. Then, the boot process hung when I tried to load initrd.img-4.4.0-45-generic. Then I tried to load memtest86+-5.01.bin from http://www.memtest.org/. At first it didn't do anything and stayed at the syslinux menu. Then I renamed it to just "memtest" and from then on it hung just like my kernel image. I also tried to use the memtest86+.bin from the Ubuntu package with the version 5.01-3ubuntu2, and that behaved the same. I've tried using the syslinux.efi version packaged with Ubuntu, "3:6.03+dfsg-11ubuntu1", and the only difference was that the memtest images rebooted instead of hung. I have verified in my tftp logs that the files were all retrieved successfully. I've also made sure my hardware is working, because I can boot to Ubuntu from a flash drive.

    What image files has anyone succeeded in loading successfully over PXE? Thanks.
  • J M EJ M E New Member Posts: 11
    The image I got to boot was a more or less generic x64 4.4 kernel with an InitRamFS built using Buildroot. Let me know if you'd like a copy. I've not attempted to boot a full distro via PXE.

    One thing that really helps in these situations is a serial port console. Allow you to see all kinds of early messages ...
  • DCleriDCleri Administrator, AAEON Posts: 592 admin
    Before releasing the new BIOS we tested PXE to boot with a Linux installer (Ubuntu) and performing a network installation.
    The server with the installer image was another UP board running ubilinux.
  • Chad ParryChad Parry New Member Posts: 2
    Yes, I just needed to pay more attention to my initramfs, because I was accidentally serving a stock kernel instead of a netboot-able kernel. Once I stopped worrying about the memtest86+ failures, it was no problem. I still don't know why I can't run memtest86+, but I can live without that. I was very happy to see Ubuntu 16.04 fire up on my UP board. Thanks!
Sign In or Register to comment.