Chrome mouse flickers on Linux

KonstantinKonstantin New Member Posts: 6
Hi:

I am having problem where using chrome with hardware acceleration mouse flickers. I used various options (disabling gpu workaround) which improved but did not solve the problem (artifacts start to appear). Also when I run GpuTest suite I get very low frame rate < 5fps (not sure if it is related).

Any ideas?

Thanks,
Konstantin

Comments

  • Oliver LeighOliver Leigh New Member Posts: 2
    I have the same problem in both Ubilinux and Lubuntu. For me the artifacts occur are mostly concentrated on the menu bar and where the cursor leaves the window.
  • KonstantinKonstantin New Member Posts: 6
    Actually it is prity good on default installation lubuntu 16.04.
  • KonstantinKonstantin New Member Posts: 6
    Thou it is slow even when chrome://gpu show hardware acceleration.
  • KonstantinKonstantin New Member Posts: 6
    edited October 2016
  • KonstantinKonstantin New Member Posts: 6
    Here is what signigicantly improved the situation (rarely see flicker). Be aware that if you go full screen with chrome (movie, 3d) flicker appears back and one need to restart X. Here is what I did:

    Create file /usr/share/X11/xorg.conf.d/20-intel.conf and add the following:

    Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "AccelMethod" "sna"
    Option "TearFree" "true"
    Option "DRI" "3"
    EndSection

    Go in chrome and type chrome://flags. Enable the following:

    Enable-zero-copy
    Enable Override Software Rendering List
    Enable Display 2D List Canvas

    Make sure that in chrome->Settings "Use hardware acceleration when available" is checked.
    When you run chrome please pass the following in the command line: --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

    Restart up board and you should be set.
  • KonstantinKonstantin New Member Posts: 6
    edited October 2016
    It turns out there is a bug - this happens only if your mouse get on the left edge of the screen in 1 cm zone. As long as mouse pointer do not get there mouse flicker is not happening.

    https://patchwork.kernel.org/patch/7887231/
Sign In or Register to comment.