WIN10 / Unable to run Dio sample

Hi All,

I'm currently working on a prototype based on an Up Board with Windows 10. I need to use some GPIO to drive peripheral devices and sensors.

After installing all the WIN10_64 drivers, I tried to run the Dio sample provided with SDK but without success. I receive a popup saying "It Cannot Open Library!".

Then, I tried to invoke AaeonIo.dll from a very simple C# app. A call to aaeonioOpen returns a zero handle.

A few unknown devices are visible in the Device manager but I see somewhere on the forum that it's not an issue to access GPIO.

Is this a driver issue ? Or a setting I missed somewhere ?

Thanks for your help.

Johann

Comments

  • Johann CHAUVIAUXJohann CHAUVIAUX New Member Posts: 10
    Updating the bios allowed me to launch the sdk sample app. However, if I change the output value of a gpio (pin 3 for example), it has no effect.

    Same result from a C# app invoking AaeonIo.dll.

    Does anyone successfully use gpio from a windows app?
  • Johann CHAUVIAUXJohann CHAUVIAUX New Member Posts: 10
    Also tried with Hi-Safe tool which is very, very slow. Changing the gpio output values has no effect.
  • Jacky KuoJacky Kuo New Member Posts: 70
    May I know your hardware configuration(RAM , eMMc size) and current BIOS revision you are using?
  • Johann CHAUVIAUXJohann CHAUVIAUX New Member Posts: 10
    edited October 2016
    Sure ! 4 Gb RAM / 64 GB eMMC / Board version 0.4. Bios has been updated 3 days ago to UPC1BM0X (09-10-2016) which allowed me to run the dio example.

    As I'm experimented with Raspberry, I played with our up board this week end and installed ubilinux. Without success, the gpio does not seem accessible (tested with RPi.GPIO, MRAA and through /sys/class/gpio).

    I did not see any option in the bios to enable or set the gpio.

    Could this be a hardware issue ? Do you have any tip/tool to check gpio availability, either on Windows or ubilinux ?

    I have to quickly validate this device for the next step of our project, thank you for your help.

    Johann
  • Jacky KuoJacky Kuo New Member Posts: 70
    Where you start to count 40-pin , are the same sequence with below picture shown?
    1.png 585.3K
  • Johann CHAUVIAUXJohann CHAUVIAUX New Member Posts: 10
    Yes, that's the way. As explained in the Board Connectors Description document, chap. 4.10.

    +5V, +3.3V and GND pins are where they are supposed to be.
  • Jacky KuoJacky Kuo New Member Posts: 70
    I can use Hi-Safe to control GPIO value(The same as Pin 3)
    1. Select "Mode" to "Output"
    2. Select "Value" to "Low"
    3. Press "Set" button. (A little bit slow...please wait a moment)
    4. The value LED should change, and your pin 3 voltage out will become 0
  • Johann CHAUVIAUXJohann CHAUVIAUX New Member Posts: 10
    I tried to play with gpio via Hi-Safe (exactly as shown above) and with the two C++ sample apps provided with the SDK. I also tried ubilinux with RPi.GPIO.

    The status change is visible in Hi-Safe (and in sample apps) but nothing happens at the pin level.

    I just did the test, whatever the mode (input/output) and value (high, low) set in Hi-Safe, the pin is always at 3.3V.

    The same applies to all accessible dio in Hi-Safe.
  • KurtKurt New Member Posts: 146 ✭✭
    I have not tried much yet on Win10 on the UP, I do have it setup to do dual booting, but I am mainly running Ubuntu. On Ubuntu, I need to run the apps that touch the GPIO pins as sudo.

    So I wonder on Windows, if you tried to run the GUI app as Administrator, does it behave any different? At least that is what I would try next...
  • Johann CHAUVIAUXJohann CHAUVIAUX New Member Posts: 10
    Thank you KurtE. This is how I have done my tests under Win10, with and without administrator rights.

    This is not the best topic for this, but under ubilinux, I get the following results:

    - an invalid argument error when I try to "echo 2 > export" in /sys/class/gpio
    - a channel already in use when I try to set a gpio with Python

    I never encountered this kind of issue with RPi, could this be a sign of a defective device ?
  • KurtKurt New Member Posts: 146 ✭✭
    again I have not used ublinux, but I am currently using Ubuntu 16.04.

    Most of my discussion on this is in the thread: https://up-community.org/forum/general-discussion/876-mraa-and-the-up-board and I believe there was another thread talking about Ubuntu 16.04...

    but again with Ubuntu, the echo fails unless you are running as Super user.
    sudo echo did not work.
    But sudo sh
    then under the sh command the echo commands worked.

    But again this is Ubuntu... your millage may differ on ubilinux.
  • Jacky KuoJacky Kuo New Member Posts: 70
    Hi JOCH,
    If you can't have a success to control GPIO under Windows nor Linux, this should not be a software setting problem.
    We assume this could be a single issue on the board itself, and we would be happy to provide RMA.
    Please go to your “order details & history “in the UP shop, and our staff will guide you from there.
Sign In or Register to comment.