UP board recognizes R200 camera but not SR300

Irene LopezIrene Lopez New Member Posts: 1
Hello,

I have the following problem and I haven't been able to find a solution on the Intel forums, so I believe this might be a better place to ask:

About a month ago I got Intel's SR300 camera and tested it with my laptop (running Win10), I connected the camera, installed the corresponding DCM, Intel's SDK and everything worked great.

But now I am using the UP board that comes as part of the Intel® RealSense™ Robotic Development Kit with the same Windows 10 (fresh install with the board connected to the internet and no pending updates) and I am getting the error: "The installer has failed to detect the Intel RealSense 3D camera in the system. The installation has been cancelled" when I try to install Intel's DCM or SDK.

I tried connecting the camera with two different cables, the one that came with the SR300 and another one that came with the R200 camera (one goes directly from the camera to the board's port and the other one needs to go through an adapted that comes with the board) but I got the exact same results.

The camera is actually recognized by the system and both the RGB and depth camera appear on my device list and I don't think that the USB 3.0 port is faulty because the UP board has no trouble with the R200 camera that comes with the kit; I only have to install the DCM, the SDK and the R200 camera works on the UP just like the SR300 did on my laptop.

To ensure that the problem wasn't caused by the R200 camera I formatted the board, reinstalled Windows from scratch and since then I have only connected the SR300 camera, but with the same results.

I believe that I should be able to use the SR300 with the UP board and I haven't found any indication to the contrary in the documentation, but I have run out of things to try so I would appreciate any ideas you can give me or if anyone can confirm if the UP board does not support the SR300 (despite being part of the Intel RealSense line).

Thank you in advance,

Comments

  • DCleriDCleri Administrator, AAEON Posts: 735 admin
    the SR300 camera has not been tested with the UP Board and it is not officially supported.

    Unfortunately we cannot really say what it is causing the issue. I advice you to use a supported camera.
Sign In or Register to comment.