Can't Boot Lakka Distro USB stick

i’m trying to boot Lakka Distro, (linux distro to transform pc into a game console) on my Up-board, i don’t succeed.

i followed the instructions for generic PC from Lakka documentation site (lakka.tv)

- downloaded Lakka image iso
- created a bootable usb-stick with win32Diskimage
-pressed F7 during startup, a popup showing only Windows Bootmanager
installed on internal Up-board drive, but i can’t see my usb stick with Lakka
distro.


- created bootable usb stick with 64bit iso and 32bit Lakka iso versions
- tried Rufus to create usb stick
- removed cmos battery for 20 mins.
- tried different usb sticks.

still no luck.

Boot Lakka usb stick on desktop PC (Intel CoreXtreme and Core2Duo) work.
Boot Windows 10 64bit usb stick and Lubuntu 64bit usb stick on Up-Board work.

thanks.

Thanks for your help.

Comments

  • DCleri
    DCleri Administrator, AAEON Posts: 1,189 admin
    Does the standard ubilinux installation process works for you?

    https://up-community.org/wiki/Installing_ubilinux

    If so I can suggest to try again using rufus and selecting MBR partition for EFI (from the partition scheme options).
    Try also a different USB port on the UP and eventually a different USB stick.

    Also please be aware that only 64bit linux is supported with the default BIOS.
  • Marco
    Marco New Member Posts: 4
    ubilinux usb stick work, boot and install.

    I chose Lakka 64bit.img and i've tried with rufus (different partition schemes) and Win32Disk imager ( suggested from Lakka documentation ) . Same results , after press F7 i can see only Windows Bootmanager , i can not see Lakka usb stick . Tried 3 different USB sticks and different usb ports .

    Thanks

    Marco