Windows 10 + Real Sense Camera >> Success (somewhat)

Chi ThaiChi Thai New Member Posts: 6
Finally I got the R-200 camera to work with Windows 10, after dealing with some "weird" issues:
1) Got all equipment hooked up with no power.
2) Power on and UP board went into Windows normally.
3) Then could hear the usual beeps while Device Manager detected the R-200 and tried to install the drivers for it.

4) Device Manager then showed 4 working Intel devices inside "Imaging Devices": AVStream, Depth, Left-Right and RGB.


5) But DCM would not install properly


6) Started to see system notifications that "Last USB device not working". Went back into Device Manager and uninstall all R-200 related drivers including all hidden related USB devices. Uninstall DCM tool also.

7) Powered down and rebooted.

8) Now see only 3 Intel devices in "Imaging Devices": Depth, Left-Right, RGB and and "ISP camera" inside "Other devices".


9) But now DCM installed properly and SDK also.

10) The "CameraExplorer" tool worked OK.


11) Got some results.

although "depth image" is poor. But this application locked itself up after around 30 s. or so. Had to reboot everything to get the system working again. Wondering if this got anything to do with that missing AVStream device?

I used the same setup on a DELL XPS desktop and had no problem at all.
Sign In or Register to comment.