Random System Hangs

Ryan WilsonRyan Wilson New Member Posts: 4
Hello.

I received an UP Board with the Intel RealSense Robotic Development Kit a couple of days ago. Since I started using it I have been plagued with random system hangs and was hoping I could get some help in tracking down the cause.

Here is the back side of the board, with the version and, I'm assuming, serial number.
0hDGNrR.jpg

I had started out by installing Ubuntu 14.04 LTS with ubilinux kernel per Intel's quickstart instructions. As a troubleshooting step, I eventually removed Ubuntu and started using ubilinux 3.0 to no avail.

The hangs are completely random. Most of the time they occur minutes after a boot, sometimes they occur just after the GRUB phase, sometimes they even occur during the GRUB phase. During the hang, sometimes I am able to move the mouse but clicking does not accomplish anything. Sometimes, the hang even freezes the mouse. I have not found a way to faithfully duplicate the hangs.

The hangs leave no traces in the kernel log, except sometimes a long string of NULL characters. The last entry before the hang is always something different.

I have tried a variety of troubleshooting steps:
[ul]
[li]Remove all USB devices (except keyboard and mouse)[/li]
[li]Change to a different keyboard and mouse[/li]
[li]Use keyboard and mouse on different ports[/li]
[li]Change HDMI cable[/li]
[li]Run stress tests on CPU, GPU, Memory, and eMMC (oddly, the longest times without system hang have been achieved after stress testing)[/li]
[li]Re-install operating system[/li]
[li]Change operating system[/li]
[/ul]
I am also aware of CHT45 in the Intel Z8000 errata and took steps to limit max_cstate via kernel parameters in GRUB. This did not help.

The only item I have not checked yet is the power supply. It is the 5V 4A adapter that came with the Intel RealSense kit. I do not have another sufficient power supply to replace it with at the moment, but I am in the process of getting something.

In the mean time, can someone offer some suggestions please? I am at a loss. At the moment, this is useless to me.

Comments

  • Javier ArteagaJavier Arteaga Emutex Posts: 163 mod
    Hi rywilson,

    Many thanks for the detailed report. We'll be looking into this.

    Hangs where you're still able to move the mouse are most likely unrelated to CHT45, so it makes sense max_cstate wouldn't help. The symptoms you describe (especially the fact that eMMC stress testing affects hang frequency, along with the NULs found within the kernel log files after a freeze), seem to suggest that eMMC is related. Please do post any MMC related error or warning that you can find in the error logs. We'd also appreciate if you shared your results with any other PSU, although I don't expect it to be a power supply issue.

    The RDK UP boards also have different BIOS settings out of the box, which makes diagnostic a bit more involved here.

    Regards
  • Ryan WilsonRyan Wilson New Member Posts: 4
    edited August 2016
    Thank you for the assistance, jarteaga.

    The new power supply did not help.

    It may be eMMC related after all. While trying to get more information for you, the system appears to have crashed for the last time. :(

    I am now immediately greeted by an EFI Shell at power up.

    5gDw1nw.jpg

    Is there anything here that is helpful to your team?
  • DCleriDCleri Administrator, AAEON Posts: 731 admin
    Hi rywilson,

    Can you try to flash the latest BIOS from our Downloads section: https://up-community.org/downloads/uefi-bios
  • Ryan WilsonRyan Wilson New Member Posts: 4
    Hello dcleri,

    I successfully completed the BIOS update and proceeded to try and re-install Ubuntu from USB. Unfortunately, it has not helped. It seems I cannot even install a Linux distribution without the board freezing before completion now. I've tried three times.

    Thank you for the suggestion anyway.
  • Al BeeAl Bee New Member Posts: 6
    @rywilson, I'm having the same problem. Were you able to resolve it?
Sign In or Register to comment.