BLE Support for UP Board

Whee Min
Whee Min New Member Posts: 18
Hi UP Creators,
Any information of Bluetooth 4.0 support modules/drivers for UP Board?

Best Regards,
Whee Min


  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Hi Whee Min

    Thanks for your question. We've tested Bluetooth 4.0 USB dongles with the BCM20702 chipset, and found that these work well. They are supported by the drivers already included in the ubilinux kernel. I've tried just a simple BLE test using the 'gatttool' bluez utility (sudo apt-get install bluez) to scan for advertising BLE devices and this works well. I don't have a suitable BLE device in my hands that I can connect to at the moment, but I will test that over the coming days.

    This is an example of a BT4.0 dongle with the BCM20702 chipset:

    Best regards,
  • Dan O'Donovan
    Dan O'Donovan Administrator, Moderator, Emutex Posts: 241 admin
    Just letting you know that I did test BLE earlier today using that USB dongle on UP (using gatttool to read characteristic values from a BLE peripheral device), and it worked well for me.
  • Robert Shelton
    Robert Shelton New Member Posts: 110
    edited June 2016
    I am attempting to use the Plugable brand Bluetooth 4.0 USB adapter to connect a Logitech keyboard and mouse. I installed Bluez and then Blueman bc the GUI entry didn't show up in Properties until both were installed. I have rebooted multiple times. The adapter appears to be partly working: i can scan and attempt to pair with my devices. Every pairing attempt, however, fails with a "failed to add device" message from Blueman.

    I have checked status of the bluetooth service using /etc/init.d/bluetooth status. Bluetooth shows as running, I did add my username to the bluetooth group. The Logitec keyboard I am attempting to connect has successfully connected to two other/different machines (Debian, Win10) in the last couple of days. I tried the Up with a different keyboard (Anker), yielding the same results.

    Any suggestions?


  • Phil
    Phil New Member Posts: 10
    I have also installed a USB Bluetooth device and it works: transfer files & images between my laptop and Up board & play audio on Bluetooth speakers! My problem appears to be when the board boots up... it causes lollipop 5.1 to keep initialising apps and then my Ethernet doesn't work. Any suggestions anybody.