migration upboard 4 => upboard 5; serial com problem

Hi,
I have a problem. Last year, I worked on this:
upboard https://up-board.org/up/specifications/
adapter https://up-shop.org/3g-wifi-bt-adapter-module.html
modem EG25 https://up-shop.org/mpcie-lte-module-kit-global.html
I installed ubuntu 20.04 and kernel upboard 5.4.0-1
yesitis@upboard:~$ uname -a
Linux upboard 5.4.0-1-generic #0~upboard4-Ubuntu SMP Thu Sep 23 01:47:49 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

This month, I bought new upboards and I did same; I installed ubuntu 20.04 and kernel upboard 5.4.0-1. But there are is some differences:
yesitis@upboard:~$ uname -a
Linux upboard 5.4.0-1-generic #0~upboard5-Ubuntu SMP Fri Jan 7 11:53:57 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

You can see upboard4 => upboard5

The modem uses ttyUSB4 serial com for AT commands. My program (C code) communicate well on upboards 4 but no byte received on serial com on upboards 5.

Do you have an idea?

Thanks.

Comments

  • garyw
    garyw New Member, Moderator, AAEON Posts: 80 admin

    @Lamoke
    Could you check the original ubuntu kernel veriosn the ttyUSB is ok or not?

  • Lamoke
    Lamoke New Member Posts: 2

    Hi,

    I did some change on termios conf struct and I received some characters on the serial com.
    It means that there are some changes about virtual serial ports (my problem was only on ttyUSBX not on ttySX).

    But I have another problem. In AT commands, when we reveive CONNECT X, it means that the modem is going to send us X bytes then OK.
    For large buffers, it's repeted serveral times. The problem is that some times, we don't receive what CONNECT tell us. Stop during sending bytes or just before sending OK. Errno tell us "ressource temporarly unvailable". When we do a read again, missing characters aren't still there.
    I couldn't solve this problem last year, but it was not so often and the system worked roughly. But with the new kernel, the problem is a big problem.

    Is anyone had this?

    Thanks

  • Wilbert
    Wilbert New Member Posts: 168 ✭✭✭

    Hi Sir,

    In order to make it more convenient for users to use, we have stopped updating the custom Kernel.
    If you need to use Linux, please install the relevant OS by yourself and use the native functions directly.
    For the HAT40pin function, we have provided relevant files for your use.
    If the original ubuntu has your above problems, we infer that it is the limitation of the OS or the tools used.

    https://github.com/up-division/pinctrl-upboard/releases

    Best Regards,
    Wilbert Lee