Unable to login to new UP Squared AI Edge X using “upsquared”, contrary to instructions.

jpsmith8488 New Member Posts: 4

I am trying to set up my new UP Squared AI Edge X. Once the Edge X has completed booting the screen displays a username “devkit”. If I select devkit I am asked to enter a password but no matter what I try I can not login successfully.* The following have not worked: upsquared, intel, ubuntu, edge, admin, root, and password. I entered terminal mode but could not find a way to change the login for the GUI. The UP Squared documentation specifies using “upsquared” for the username and password but this did not work. I would appreciate any advice to allow me to login and then to replace devkit with my login credentials. Many thanks.

*A photo of the login display:

Best Answers


  • jpsmith8488
    jpsmith8488 New Member Posts: 4

    Hi Camillus,
    Thank you for trying to help me but the combination of the Ubuntu username “devkit” and password “upsquared” did not grant me access. I tried rebooting then pressing “esc” as soon I saw the “Up2 Bridge the Gap” to try to get to the root shell but the system asked for a password and here too “upsquared” failed. I would appreciate any additional suggestions you might have.

  • jpsmith8488
    jpsmith8488 New Member Posts: 4

    Note: I also tried ctrl-alt-F4 to try to reach the boot menu. The Ubuntu login screen changed to show:

    I tried username “upsquared” and password “upsquared” without success.

    Many thanks for any advice.