PPA repos are no longer available

languille11 New Member Posts: 1

Hello, I am looking to install the upxtreme-UP-WHL01 5.4.0-1-generic linux kernel but the repos is no longer available.
If I add the ppa's I get this error:
he user named '~aaeon-cm' has no PPA named 'ubuntu/5.4-upboard'

This url doesn't work either

Where can I find the packages allowing to install this kernel on an up
Thank you


  • garrarq
    garrarq New Member Posts: 1

    Hi all, I have a similar issue as @languille11, and want people to know that this issue is not specific to him.

    I already installed the kernel from aaeon-cm/5.4-upboard/ubuntu, and when I run

    sudo apt update

    I get the following:

    Hit:1 http://packages.ros.org/ros2/ubuntu focal InRelease
    Hit:2 http://archive.ubuntu.com/ubuntu focal InRelease
    Hit:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease
    Ign:4 http://ppa.launchpad.net/aaeon-cm/5.4-upboard/ubuntu focal InRelease
    Hit:5 http://archive.ubuntu.com/ubuntu focal-backports InRelease
    Hit:6 http://archive.ubuntu.com/ubuntu focal-security InRelease
    Err:7 http://ppa.launchpad.net/aaeon-cm/5.4-upboard/ubuntu focal Release
      404  Not Found [IP: 80]
    Reading package lists... Done
    E: The repository 'http://ppa.launchpad.net/aaeon-cm/5.4-upboard/ubuntu focal Release' no longer has a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.

    I hope this helps.

  • UpBored
    UpBored New Member Posts: 16

    This would all be so much easier if there was an official image which could easily be done with



  • Kahren
    Kahren New Member Posts: 5

    First I have the same issue. Second, how do we know if someone is looking into this issue as comments seem to be presented as** answers**

  • nicSB
    nicSB New Member Posts: 1

    @DCleri could you help? The instructions provided here seem outdated. Where can we get the latest kernel for the UP boards? All the related repositories and packages hosted on Launchpad are no longer accessible.
    Thank you!

  • Terry
    Terry New Member Posts: 1

    Can confirm that this is a problem here and will be impacting all Amber Robotics customers using the B1 robot arm. In my case, I am gettng a 403 error:

    ~$ sudo apt-get update
    Hit:1 http://ppa.launchpad.net/nemh/systemback/ubuntu xenial InRelease
    Err:2 http://ppa.launchpad.net/aaeon-cm/5.4-upboard/ubuntu focal InRelease
      403  Forbidden [IP: 80]
  • nattip
    nattip New Member Posts: 2

    I, too, am having this same issue. A few days ago I was getting the 404 Not found error, and now today am receiving the 403 forbidden response.

  • rogertsai(AAEON)
    rogertsai(AAEON) New Member Posts: 350 ✭✭✭
    edited May 2022

    Hello guys
    The ppa & files link are under repair and maintenance
    Please click the link below to download the next Debian packages from our backup Launchpad

  • Richard_Axon
    Richard_Axon New Member Posts: 1

    Same issue here...

  • Pieter Jordaan
    Pieter Jordaan New Member Posts: 12

    @rogertsai(AAEON) said:
    Hello guys
    The ppa & files link are under repair and maintenance
    Please click the link below to download the next Debian packages from our backup Launchpad

    I have gone to this repo, and tried the 5.8 ppa, but there is no linux-image-extra or similar, leaving GPIO and other hardware features not working.

  • Remni
    Remni New Member Posts: 2
  • DCleri
    DCleri Administrator, AAEON Posts: 1,213 admin

    Hello Everybody and sorry for the late reply.

    Unfortunately we had issues with the old repositories and we had to create a new one with the same packages but under a new PPA name.

    This is now definitive and it would require you to remove the existing aaeon-cm repos and add the new ones.

    All the kernels and other packages have been added, you can find a complete list here:

    All the related tutorials include now the new repositories, for example:


    sorry for the inconvenience and please let us know if you are still encountering any issue.

  • UpBored
    UpBored New Member Posts: 16
    edited July 2022

    Given that the 5.8 kernel is no longer supported by Ubuntu for 20.04.x[1], is not an LTS kernel listed by the Linux Kernel Team[2], or receiving updates by patches for sold products and lacking a current or long upgrade path[3], you should stop using this device all together as it has been abandoned by every party involved on first sale for secure computing which may be a liability issue, even though UP still sells the device[4]. The 5.4 kernel would, if upstreamed, or automatically merged or broken out, be compatible with Ubuntu 20.04 until 2030+. Unfortunately that is not the case. The ABI will not change and this should have been the default four years ago when 18.04 was looking to have such a long lifespan in comparison to other LTS Ubuntu releases.

    This is a bait and switch for new purchases. No mention of a forced "Day One" payment plan for active kernel maintenance is mentioned on the sale page. Many industries will require this for regulatory and liability reasons. They even mention compatibility and regulated industry use cases on the sale page, today. How can you advertise this without even a mention of how that happens.

    [1] https://ubuntu.com/about/release-cycle#ubuntu-kernel-release-cycle=
    [2] https://kernel.org/
    [3] https://forum.up-community.org/discussion/comment/12927/#Comment_12927
    [4] https://up-shop.org/up-board-series.html

Privacy Policy