RoboMaker Pro kit missing source files ROS 2 not working

robohkr New Member Posts: 3


I bought this up squared RoboMaker Pro Kit in order to learn ROS 2.

I encountered some problems with missing source code and documentation and when I tried to contact the maintainer listed for the hamster_driver package, the email bounced back.

It seems that the kit was actually built and tested for ROS 1 and then patched to work with ROS 2. This is clear from the installation script which installs both ROS1 & ROS2 and associated packages here:

I modified the script to download just the ROS 2 portions (I can send it to you if that's helpful) and then tried to colcon build the downloaded hamster2_ws workspace, however the hamster_driver package failed due to missing source files:

  • driver_test.cpp
  • hamster_driver_node.cpp
    The package actually contains no source (src) folder/files. There is only a launch folder. I also checked in the ROS1 workspace hamster_ws but the files aren't there either.
  1. Could someone send me a link to the source code needed to build the driver code for RoboMakerPro on ROS 2?
  2. I would like to at least get teleoperation working so that I can move on to testing Nav2 on the platform. Please send the necessary files for this.
  3. The documentation is extremely lean: so it seems like the videos on the advert are from ROS 1


Privacy Policy