Ubuntu Server 20.04 new install: Blank screen after Grub?

seanp25
seanp25 New Member Posts: 3
edited March 15 in UP Core Linux

New Up Core 1GB board.
I have Ubuntu live server image from the wiki on a USB key.
It boots into Grub, I can navigate that menu, and choose Install Ubuntu.
The next screen is blank, only with a keyboard accessiblity icon in the top right, I can click that and an On Screen Keyboard appears, but nothing else happens after waiting 15 mins, just a blank screen.
Any tips on how to get past this?
I'm hoping 1GB RAM should be plenty for the server (no desktop) Ubuntu install.

Answers

  • seanp25
    seanp25 New Member Posts: 3
    edited March 15

    Two other bits of info: I've tried 18.04 and 20.04 Ubuntu server and neither of them get past the Grub screen. Also tried different USB keys, written using Etcher.

    When I select any of the "Install Ubuntu" options, the screen goes blank (apart from OSD icon), the data activity light on my USB key flashes for another two seconds or so, and then stops.

    Ubuntu Server recommends 1GB of RAM (so minimum requirement must be a bit lower than that?): https://ubuntu.com/server/docs/installation

    So it should be OK for Up Core 1GB RAM?

  • camillus
    camillus Administrator, Moderator, AAEON Posts: 150 admin

    Hi @seanp25 ,

    Can you try to make sure you have the latest BIOS for UP Core, you can download from here, next to that can you try to flash Ubuntu server image using rufus and retry the installation. Let us know if it works.

  • seanp25
    seanp25 New Member Posts: 3
    edited March 21

    Hi @camillus , thanks for the tips.

    I had not upgraded the BIOS, I will do that in the next few days.

    In the meantime, I was able to get Lubuntu 16.04 installed, and I ran do-release-upgrade from there to go to 18.04 and then again to 20.04, which I have running very well now as a headless server.

    The system seems to hang when I try to sudo reboot, I saw a note about this in the wiki and I applied the fix (using blacklist), but it still hangs. I will try the BIOS update and see if that works to fix it.

    Thanks again.