UPXTREME not booting anymore

Options

Hi,

We have an issue with an UP Xtreme board UPX-WHLI7-A20-16064.
We have already used this board a few time without any issue.

Yesterday, the board was running normally, powered by a standard 19V AC adapter, in our lab.
An engineer came close to the fan and the cooler with his hand (without touching it) to feel the temperature. Then the board suddenly shut down as the engineer felt a brief electric discharge. Probably an electrostatic discharge from the metal radiant on the cooler.

Since this moment, it is impossible the turn on the board.
When we push the ON button, the fan doesn’t turn (yet sometimes it briefly turns), the USB ports have no power, and the HDMI display is black (Ubuntu is on the board).
Even if the board seems completely not running, if we let the power supply and press the ON button, we can feel that the cooler is hotter and hotter, so something is still happening.

We tried to disconnect the CMOS battery for a few minutes and reconnect it, then tried to power on, but it failed.

Could you give us some support regarding this issue ? Should the board sent back to UP ?

I contacted the UP Store support and they asked me to post my issue here.

Thanks,
Alexis

Comments

Privacy Policy