i2c device found on win 10 x64 ?

Kelo
Kelo New Member Posts: 3

Hi, has anyone successfully found any i2c device on Up Sqared Win 10 x64 ? I can run UpI2cTEstTool demo, but no device found. Tried I2C0, I2C1, tried different sensors (MPU6050 board, BMP170,...), checked wiring 10x times, in BIOS pins are associated to I2C (not GPIO).

Thank you...

Tagged:

Answers

  • TheZNerd
    TheZNerd New Member Posts: 28

    I was able to get the demo app working. Make sure you have the SDK installed on the board.

    I'm struggling with getting this to work with .NET Core 6 however, because System.Device.I2c does not have an I2cController class which the demo app makes use of. Additionally, I'm not 100% certain of the point of the UpBridge.Up() function as the object it is being assigned to is never referenced? Maybe it's just a function to make sure the communication bridge is up? The lack of documentation and support here really makes me want to return this and get something else.

  • TheZNerd
    TheZNerd New Member Posts: 28

    Ugh, the SDK can't be used with .NET Core 6.