UART port works on WINDOWS 10 using Minicom, Device Monitoring Studio, etc. but not on Putty

Earsistemas New Member Posts: 27
edited October 2021 in UP Core Plus Windows

I am trying to connect a board (UP CORE PLUS) via UART, that uses windows 10, to another microsystem board. I know that the port is working properly because I can monitorize it via windows Minicom or Device Monitoring Studio (DMS). But when I use windows PUTTY, I always get the same error:

unable to open connection to com1: error 87 the parameter is not correct

Please, any help is wellcome. Why a port is working on windows DMS and not on windows PUTTY?
Thank you


  • camillus
    camillus Administrator, Moderator, AAEON Posts: 188 admin

    Hi @Earsistemas ,

    Check that you are using the correct COM port for Putty, One way of finding out, open device manager before plugging the USB to UART cable and monitor for the new COM port. The DMS and Putty will not necessarily use the same COM port.

  • Earsistemas
    Earsistemas New Member Posts: 27

    Thanks Camillus for your quick answer. Let me explain a little more and include some screenshots: In windows 10, the UP CORE PLUS creates the UART ports perfectly, and you can see them in the device manager:

    When you test them, the USB and UART ports are working fine. I have monitorized them using DMS or Moba (minicom engine) in windows:

    But, when we try COM1 using PUTTY (windows), we always get this error:

    COM3 and all USB virtual PORTS work fine in PUTTY, but it is imposible to work with port COM1, which is the UART port we need.
    The reason why we need to see information via COM1 in PUTTY windows is that we need to see the port COM1 in the Python program we use in our system. We have been told that if PUTTY windows does not see the UART port, Python (pyserial) neither. This is why we need to test COM1 via windows PUTTY.
    Our system works perfectly in Ubuntu 20.04: all ports work fine including COM1 using Cutecom.

    Thanks for your kind help.

  • Earsistemas
    Earsistemas New Member Posts: 27
  • camillus
    camillus Administrator, Moderator, AAEON Posts: 188 admin

    Hi @Earsistemas ,

    We need more information like the below screenshot. Can you show COM Port Property BIOS device name to further debug this.

  • Kelo
    Kelo New Member Posts: 3

    Hi, I have exactly the same problem. My COM2 Property is: _SB.PCI0.URT2.VUT1

  • camillus
    camillus Administrator, Moderator, AAEON Posts: 188 admin

    Hi @Kelo,

    Thanks, we will debug this and get back to you soon.

  • camillus
    camillus Administrator, Moderator, AAEON Posts: 188 admin


    We have tested and see that Putty has an issue to open UP Board COM port, but ExtraPuTTY v0.29-RC2 worked as you can see in the screenshot below. So this is likely to be a driver compatibility issue with Putty.

  • SeriousSam
    SeriousSam New Member Posts: 4

    Hi @Earsistemas,

    recently I was trying to use UART port on UP Squared board and got the same results as you. I have determined that the port does not support full functionalities as terminal programs Realterm or Putty would like to use. UP Squared board does not like setting fDtrControl in comDCB. I have successfully used a workaround in Python with pyserial library by setting dsrdtr and ser.dtr to false before opening the serial port like this:

    import serial
    ser = serial.Serial(
    while True:

    Maybe this workaround will work for your board also. You may have to define ser.port= to you COM port, for example ser.port='COM1' or try with device path as in above example. You can check the device path with mincomm.exe -list.