Linux share_net feature (Wifi on device 1 to Ethernet Port on device 2) working on only one LAN Port

sgr_gptsgr_gpt New Member Posts: 4

Hi everyone,

I have been trying to get internet working on my UP Xtreme board through the "Shared to other computers" option in Linux. I am facing this strange issue wherein I am able to share my internet connection (from wifi) on Laptop to UPX only on one LAN connection. While trying to do so on the other LAN Port the ping is still tried from the IP of the first LAN port by default. I have tried this on multiple UP Xtreme boards and with Ubuntu 16 as well as 18 distributions, but the issue still persists.

Any suggestions would be appreciated to figure this out.

Thank you.

Tagged:

Comments

  • DCleriDCleri Administrator, AAEON Posts: 1,132 admin

    can you please provide a drawing or network diagram to understand what you are trying to achieve and where the issue happen?

  • sgr_gptsgr_gpt New Member Posts: 4

    Hi,
    There isn't much of a network here actually. However I have tried to pen down the issue in a diagram. Please see if it helps to get a better picture of the problem.

    So basically I am able to achieve this thing on LAN Port 1 but not on LAN Port 2. And its the case for all 3 UP Xtreme boards I had with me.

    Thank you for the help!

  • DCleriDCleri Administrator, AAEON Posts: 1,132 admin

    ok so you confirm the share is working but on LAN port 2 it is not.

    Have you tried to use a switch in between? I think it might be the cable, Intel i210 do not play well with automatic crossover and you would need a crossover cable.

  • sgr_gptsgr_gpt New Member Posts: 4

    Thanks for the prompt response.

    I have tried using a switch in between with regular ethernet cables on either end, but to no avail. The issue still persists. Does this mean I need to use this feature with crossover cables?

  • DCleriDCleri Administrator, AAEON Posts: 1,132 admin

    If you have a switch in between you don't need a crossover cable.

    Have you tried to disable the other network interface from the network configuration tool, so that only LAN port 2 is used?

  • sgr_gptsgr_gpt New Member Posts: 4

    No, I haven't tried that. I will do so and update here. However, still it wouldn't solve my issue as I also do need to use both of them simultaneously.

Sign In or Register to comment.

Tagged